[packages_10.03.2] vips: merge r28062, r28064, r28533, r29057
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 18:51:54 +0000 (18:51 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 18:51:54 +0000 (18:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30066 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/vips/Makefile
libs/vips/patches/001-no_cpp.patch

index ec30c00..2fa68d4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vips
-PKG_VERSION:=7.24.1
-PKG_RELEASE:=1
+PKG_VERSION:=7.26.3
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.vips.ecs.soton.ac.uk/supported/7.24/
-PKG_MD5SUM:=7e9d34960c3453f3b8d1d4300fe4b7a0
+PKG_SOURCE_URL:=http://www.vips.ecs.soton.ac.uk/supported/7.26/
+PKG_MD5SUM:=1fbf164ef0da8e835a036c56ff659e8e
 PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
@@ -21,20 +21,13 @@ include $(INCLUDE_DIR)/nls.mk
 
 PKG_INSTALL=1
 
-define Package/vips/Default
-  TITLE:=vips
-  URL:=http://www.vips.ecs.soton.ac.uk/
-endef
-
 define Package/vips
   $(call Package/vips/Default)
   SECTION:=multimedia
   CATEGORY:=Multimedia
-  DEPENDS:=+libjpeg +glib2 +libxml2 +imagemagick +libfreetype $(INTL_DEPENDS)
-endef
-
-define Package/vips/description
-  An image manipulation library.
+  TITLE:=An image manipulation library
+  URL:=http://www.vips.ecs.soton.ac.uk/
+  DEPENDS:=+glib2 +libexif +libjpeg +libpng +libxml2 $(INTL_DEPENDS)
 endef
 
 TARGET_LDFLAGS+= \
@@ -43,7 +36,22 @@ TARGET_LDFLAGS+= \
 CONFIGURE_ARGS += \
        --disable-cxx \
        --disable-threads \
-       --without-liboil
+       --without-cfitsio \
+       --without-fftw3 \
+       --without-lcms \
+       --without-magick \
+       --without-matio \
+       --without-OpenEXR \
+       --without-orc \
+       --without-pangoft2 \
+       --without-python \
+       --without-tiff \
+       --without-v4l \
+       --without-x \
+       --without-zip \
+       --with-jpeg \
+       --with-libexif \
+       --with-png \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/vips
index 1511add..9c4671f 100644 (file)
@@ -1,7 +1,7 @@
-diff -u --recursive vips-7.24.1-vanilla/configure.in vips-7.24.1/configure.in
---- vips-7.24.1-vanilla/configure.in   2011-03-29 22:09:45.465282663 -0500
-+++ vips-7.24.1/configure.in   2011-03-29 22:18:40.786482911 -0500
-@@ -143,7 +143,6 @@
+diff -u --recursive vips-7.26.3-vanilla/configure.in vips-7.26.3/configure.in
+--- vips-7.26.3-vanilla/configure.in   2011-10-07 20:43:26.474844552 -0500
++++ vips-7.26.3/configure.in   2011-10-07 21:00:33.633107256 -0500
+@@ -142,7 +142,6 @@
  AC_PROG_AWK
  AC_PROG_CC
  AC_PROG_CC_STDC
@@ -9,23 +9,77 @@ diff -u --recursive vips-7.24.1-vanilla/configure.in vips-7.24.1/configure.in
  AC_C_CONST
  AC_C_RESTRICT
  AC_PROG_RANLIB
-@@ -615,7 +614,6 @@
+@@ -150,45 +149,6 @@
+ AC_PROG_LN_S
+ AM_WITH_DMALLOC
+-# vips_PROG_CXX_WORKS
+-# Check whether the C++ compiler works.
+-AC_DEFUN([vips_PROG_CXX_WORKS],
+-  [AC_REQUIRE([AC_PROG_CXX])dnl
+-   AC_CACHE_CHECK([whether the C++ compiler works],
+-   [vips_cv_prog_cxx_works],
+-   [AC_LANG_PUSH([C++])
+-    AC_LINK_IFELSE([AC_LANG_PROGRAM([], [])],
+-                   [vips_cv_prog_cxx_works=yes],
+-                   [vips_cv_prog_cxx_works=no])
+-    AC_LANG_POP([C++])])
+-])
+-
+-# option to build without C++
+-# handy for some embedded applications
+-# also, including C++ source causes link problems on some
+-# platforms, so have an option to disable it
+-AC_ARG_ENABLE(cxx, 
+-  AS_HELP_STRING([--enable-cxx], [build C++ components (default: test)]))
+-
+-if test x"$enable_cxx" != x"no"; then
+-  vips_PROG_CXX_WORKS
+-  if test x"$vips_cv_prog_cxx_works" = x"yes"; then 
+-    AC_DEFINE(ENABLE_CXX,1,[build C++ components])
+-    AM_CONDITIONAL(ENABLE_CXX, true)
+-    # need -lstdc++ for (eg.) the C++ format loaders
+-    # this gets added to vips-7.xx.pc to help mingw and friends link programs
+-    # using libvips
+-    VIPS_CXX_LIBS="-lstdc++"
+-    enable_cxx=yes
+-  fi
+-fi
+-
+-if test x"$enable_cxx" != x"yes"; then
+-  AM_CONDITIONAL(ENABLE_CXX, false)
+-  VIPS_CXX_LIBS=""
+-  enable_cxx=no
+-fi
+-
+ # we need a fully expanded version of $libdir
+ # without this we get something like
+ #    define VIPS_LIBDIR ${exec_prefix}/lib
+@@ -614,7 +574,6 @@
+ AC_SUBST(VIPS_CFLAGS)
+ AC_SUBST(VIPS_INCLUDES)
+ AC_SUBST(VIPS_LIBS)
+-AC_SUBST(VIPS_CXX_LIBS)
+ AC_SUBST(PACKAGES_USED)
+ # you'd think we could have 
+@@ -622,7 +581,6 @@
  # in AC_OUTPUT, but that seems to break for some combinations of sh/m4
  AC_OUTPUT([
-       vips-7.24.pc
--      vipsCC-7.24.pc
+       vips-7.26.pc
+-      vipsCC-7.26.pc
        Makefile 
        libvips/include/vips/version.h 
        libvips/include/Makefile 
-@@ -624,7 +622,6 @@
-       libvips/acquire/Makefile 
+@@ -630,7 +588,6 @@
+       libvips/Makefile 
        libvips/arithmetic/Makefile 
        libvips/boolean/Makefile 
 -      libvips/cimg/Makefile 
        libvips/colour/Makefile 
        libvips/conversion/Makefile 
        libvips/convolution/Makefile 
-@@ -641,9 +638,6 @@
+@@ -647,9 +604,6 @@
        libvips/relational/Makefile 
        libvips/resample/Makefile 
        libvips/video/Makefile 
@@ -33,19 +87,19 @@ diff -u --recursive vips-7.24.1-vanilla/configure.in vips-7.24.1/configure.in
 -      libvipsCC/include/vips/Makefile 
 -      libvipsCC/Makefile 
        tools/Makefile 
-       tools/iofuncs/Makefile 
-       tools/mosaicing/Makefile 
-@@ -655,7 +649,6 @@
-       tools/scripts/light_correct 
-       tools/scripts/shrink_width 
+       tools/batch_crop 
+       tools/batch_image_convert 
+@@ -657,7 +611,6 @@
+       tools/light_correct 
+       tools/shrink_width 
        swig/Makefile 
 -      swig/vipsCC/Makefile 
        swig/python/setup.py 
        man/Makefile
        doc/Makefile
-diff -u --recursive vips-7.24.1-vanilla/libvips/Makefile.am vips-7.24.1/libvips/Makefile.am
---- vips-7.24.1-vanilla/libvips/Makefile.am    2011-03-29 22:09:45.525280200 -0500
-+++ vips-7.24.1/libvips/Makefile.am    2011-03-29 22:16:08.223081415 -0500
+diff -u --recursive vips-7.26.3-vanilla/libvips/Makefile.am vips-7.26.3/libvips/Makefile.am
+--- vips-7.26.3-vanilla/libvips/Makefile.am    2011-10-07 20:43:26.909839013 -0500
++++ vips-7.26.3/libvips/Makefile.am    2011-10-07 20:45:25.074274823 -0500
 @@ -1,14 +1,3 @@
 -# only build in the cimg dir if C++ is enabled
 -if ENABLE_CXX
@@ -60,8 +114,8 @@ diff -u --recursive vips-7.24.1-vanilla/libvips/Makefile.am vips-7.24.1/libvips/
 -
  SUBDIRS = \
        include \
-       acquire \
-@@ -19,7 +8,6 @@
+       arithmetic \
+@@ -18,7 +7,6 @@
        conversion \
        deprecated \
        convolution \
@@ -69,17 +123,22 @@ diff -u --recursive vips-7.24.1-vanilla/libvips/Makefile.am vips-7.24.1/libvips/
        format \
        freq_filt \
        histograms_lut \
-@@ -36,9 +24,6 @@
- lib_LTLIBRARIES = libvips.la
+@@ -37,14 +25,6 @@
+ # empty means default to C linking
+ libvips_la_SOURCES = 
  
- libvips_la_SOURCES = dummy.c 
+-# if we have C++ components enabled, make sure we link the top-level with c++
+-#
+-# sadly the if/enndif isn't enough to stop automake detecting a c++ link even
+-# when c++ is disabled ... comment out this line if you have linking problems
 -if ENABLE_CXX
--libvips_la_SOURCES += dummy2.cc
+-nodist_EXTRA_libvips_la_SOURCES = cimg/dummy2.cxx
 -endif
+-
  # DLLs need dependant libs there too ... put @VIPS_LIBS@ at the end
  libvips_la_LIBADD = \
-@@ -50,7 +35,6 @@
+       resample/libresample.la \
+@@ -54,7 +34,6 @@
        conversion/libconversion.la \
        convolution/libconvolution.la \
        deprecated/libdeprecated.la \
@@ -87,7 +146,7 @@ diff -u --recursive vips-7.24.1-vanilla/libvips/Makefile.am vips-7.24.1/libvips/
        format/libformat.la \
        freq_filt/libfreq_filt.la \
        histograms_lut/libhistograms_lut.la \
-@@ -64,13 +48,6 @@
+@@ -68,13 +47,6 @@
        video/libvideo.la \
        @VIPS_LIBS@
  
@@ -101,10 +160,10 @@ diff -u --recursive vips-7.24.1-vanilla/libvips/Makefile.am vips-7.24.1/libvips/
 -
 -EXTRA_DIST = \
 -      $(C_DIST_DIR)
-diff -u --recursive vips-7.24.1-vanilla/libvips/resample/Makefile.am vips-7.24.1/libvips/resample/Makefile.am
---- vips-7.24.1-vanilla/libvips/resample/Makefile.am   2011-03-29 22:09:45.546279339 -0500
-+++ vips-7.24.1/libvips/resample/Makefile.am   2011-03-29 22:16:28.918185323 -0500
-@@ -2,23 +2,6 @@
+diff -u --recursive vips-7.26.3-vanilla/libvips/resample/Makefile.am vips-7.26.3/libvips/resample/Makefile.am
+--- vips-7.26.3-vanilla/libvips/resample/Makefile.am   2011-10-07 20:43:27.173835707 -0500
++++ vips-7.26.3/libvips/resample/Makefile.am   2011-10-07 20:45:49.360933471 -0500
+@@ -2,22 +2,6 @@
  # you'd think we could just define a couple of variables, but that seems to
  # confuse libtool and make it link the library with g++
  # instead, have two completely different paths
@@ -114,7 +173,6 @@ diff -u --recursive vips-7.24.1-vanilla/libvips/resample/Makefile.am vips-7.24.1
 -      im_affine.c \
 -      interpolate.c \
 -      im_shrink.c \
--      im_stretch3.c \
 -      im_rightshift_size.c \
 -      transform.c \
 -      resample_dispatch.c \
@@ -128,7 +186,7 @@ diff -u --recursive vips-7.24.1-vanilla/libvips/resample/Makefile.am vips-7.24.1
  
  libresample_la_SOURCES = \
        im_affine.c \
-@@ -29,15 +12,6 @@
+@@ -27,15 +11,6 @@
        transform.c \
        resample_dispatch.c 
  
@@ -144,3 +202,180 @@ diff -u --recursive vips-7.24.1-vanilla/libvips/resample/Makefile.am vips-7.24.1
  noinst_LTLIBRARIES = libresample.la
  
  INCLUDES = -I${top_srcdir}/libvips/include @VIPS_CFLAGS@ @VIPS_INCLUDES@ 
+diff -u --recursive vips-7.26.3-vanilla/Makefile.am vips-7.26.3/Makefile.am
+--- vips-7.26.3-vanilla/Makefile.am    2011-10-07 20:43:26.476844503 -0500
++++ vips-7.26.3/Makefile.am    2011-10-07 22:31:54.034586656 -0500
+@@ -1,43 +1,17 @@
+-
+-# turn off libvipsCC if C++ is disabled
+-if ENABLE_CXX
+-C_COMPILE_DIR = libvipsCC
+-C_DIST_DIR =
+-C_PKGCONFIG = vipsCC-7.${VIPS_MINOR_VERSION}.pc
+-
+-# turn on Python if we can (requires C++)
+-if HAVE_PYTHON
+-P_COMPILE_DIR = swig
+-P_DIST_DIR =
+-endif
+-
+-else
+-C_COMPILE_DIR =
+-C_DIST_DIR = libvipsCC 
+-C_PKGCONFIG =
+-P_COMPILE_DIR =
+-P_DIST_DIR = swig
+-endif
+-
+ SUBDIRS = \
+       libvips \
+       tools \
+       po \
+       man \
+-      doc \
+-      $(C_COMPILE_DIR) \
+-      $(P_COMPILE_DIR) 
++      doc
+ EXTRA_DIST = \
+       m4 \
+       benchmark \
+       bootstrap.sh \
+       vips-7.${VIPS_MINOR_VERSION}.pc.in \
+-      vipsCC-7.${VIPS_MINOR_VERSION}.pc.in \
+       acinclude.m4 \
+-      depcomp \
+-      $(C_DIST_DIR) \
+-      $(P_DIST_DIR)
++      depcomp
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = vips-7.${VIPS_MINOR_VERSION}.pc $(C_PKGCONFIG)
+diff -u --recursive vips-7.26.3-vanilla/Makefile.in vips-7.26.3/Makefile.in
+--- vips-7.26.3-vanilla/Makefile.in    2011-10-07 20:43:26.766840803 -0500
++++ vips-7.26.3/Makefile.in    2011-10-07 22:30:18.980820947 -0500
+@@ -37,7 +37,6 @@
+ subdir = .
+ DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
+       $(srcdir)/Makefile.in $(srcdir)/config.h.in \
+-      $(srcdir)/vips-7.26.pc.in $(srcdir)/vipsCC-7.26.pc.in \
+       $(top_srcdir)/configure $(top_srcdir)/swig/python/setup.py.in \
+       AUTHORS COPYING ChangeLog INSTALL NEWS THANKS TODO \
+       config.guess config.sub depcomp install-sh ltmain.sh missing \
+@@ -51,7 +50,7 @@
+  configure.lineno config.status.lineno
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = config.h
+-CONFIG_CLEAN_FILES = vips-7.26.pc vipsCC-7.26.pc swig/python/setup.py
++CONFIG_CLEAN_FILES = vips-7.26.pc swig/python/setup.py
+ CONFIG_CLEAN_VPATH_FILES =
+ SOURCES =
+ DIST_SOURCES =
+@@ -92,7 +91,7 @@
+       distdir dist dist-all distcheck
+ ETAGS = etags
+ CTAGS = ctags
+-DIST_SUBDIRS = libvips tools po man doc libvipsCC swig
++DIST_SUBDIRS = libvips tools po man doc swig
+ DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+ distdir = $(PACKAGE)-$(VERSION)
+ top_distdir = $(distdir)
+@@ -146,10 +145,6 @@
+ CFLAGS = @CFLAGS@
+ CPP = @CPP@
+ CPPFLAGS = @CPPFLAGS@
+-CXX = @CXX@
+-CXXCPP = @CXXCPP@
+-CXXDEPMODE = @CXXDEPMODE@
+-CXXFLAGS = @CXXFLAGS@
+ CYGPATH_W = @CYGPATH_W@
+ DATADIRNAME = @DATADIRNAME@
+ DEFS = @DEFS@
+@@ -262,7 +257,6 @@
+ USE_NLS = @USE_NLS@
+ VERSION = @VERSION@
+ VIPS_CFLAGS = @VIPS_CFLAGS@
+-VIPS_CXX_LIBS = @VIPS_CXX_LIBS@
+ VIPS_EXEEXT = @VIPS_EXEEXT@
+ VIPS_INCLUDES = @VIPS_INCLUDES@
+ VIPS_LIBDIR = @VIPS_LIBDIR@
+@@ -285,7 +279,6 @@
+ abs_top_builddir = @abs_top_builddir@
+ abs_top_srcdir = @abs_top_srcdir@
+ ac_ct_CC = @ac_ct_CC@
+-ac_ct_CXX = @ac_ct_CXX@
+ ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
+ am__include = @am__include@
+ am__leading_dot = @am__leading_dot@
+@@ -337,39 +330,21 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-@ENABLE_CXX_FALSE@C_COMPILE_DIR = 
+-# turn off libvipsCC if C++ is disabled
+-@ENABLE_CXX_TRUE@C_COMPILE_DIR = libvipsCC
+-@ENABLE_CXX_FALSE@C_DIST_DIR = libvipsCC 
+-@ENABLE_CXX_TRUE@C_DIST_DIR = 
+-@ENABLE_CXX_FALSE@C_PKGCONFIG = 
+-@ENABLE_CXX_TRUE@C_PKGCONFIG = vipsCC-7.${VIPS_MINOR_VERSION}.pc
+-@ENABLE_CXX_FALSE@P_COMPILE_DIR = 
+-
+-# turn on Python if we can (requires C++)
+-@ENABLE_CXX_TRUE@@HAVE_PYTHON_TRUE@P_COMPILE_DIR = swig
+-@ENABLE_CXX_FALSE@P_DIST_DIR = swig
+-@ENABLE_CXX_TRUE@@HAVE_PYTHON_TRUE@P_DIST_DIR = 
+ SUBDIRS = \
+       libvips \
+       tools \
+       po \
+       man \
+       doc \
+-      $(C_COMPILE_DIR) \
+-      $(P_COMPILE_DIR) 
+ EXTRA_DIST = \
+       m4 \
+       benchmark \
+       bootstrap.sh \
+       vips-7.${VIPS_MINOR_VERSION}.pc.in \
+-      vipsCC-7.${VIPS_MINOR_VERSION}.pc.in \
+       acinclude.m4 \
+       depcomp \
+-      $(C_DIST_DIR) \
+-      $(P_DIST_DIR)
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = vips-7.${VIPS_MINOR_VERSION}.pc $(C_PKGCONFIG)
+@@ -431,8 +406,6 @@
+       -rm -f config.h stamp-h1
+ vips-7.26.pc: $(top_builddir)/config.status $(srcdir)/vips-7.26.pc.in
+       cd $(top_builddir) && $(SHELL) ./config.status $@
+-vipsCC-7.26.pc: $(top_builddir)/config.status $(srcdir)/vipsCC-7.26.pc.in
+-      cd $(top_builddir) && $(SHELL) ./config.status $@
+ swig/python/setup.py: $(top_builddir)/config.status $(top_srcdir)/swig/python/setup.py.in
+       cd $(top_builddir) && $(SHELL) ./config.status $@
+diff -u --recursive vips-7.26.3-vanilla/tools/Makefile.am vips-7.26.3/tools/Makefile.am
+--- vips-7.26.3-vanilla/tools/Makefile.am      2011-10-07 20:43:26.495844193 -0500
++++ vips-7.26.3/tools/Makefile.am      2011-10-07 22:34:56.215304397 -0500
+@@ -16,9 +16,6 @@
+ INCLUDES = -I${top_srcdir}/libvips/include @VIPS_CFLAGS@ @VIPS_INCLUDES@
+ AM_LDFLAGS = @LDFLAGS@ 
+ LDADD = @VIPS_CFLAGS@ ${top_builddir}/libvips/libvips.la @VIPS_LIBS@
+-if ENABLE_CXX
+-LDADD += @VIPS_CXX_LIBS@
+-endif
+ bin_SCRIPTS = \
+       light_correct \
+diff -u --recursive vips-7.26.3-vanilla/vips-7.26.pc.in vips-7.26.3/vips-7.26.pc.in
+--- vips-7.26.3-vanilla/vips-7.26.pc.in        2011-10-07 20:43:26.769840766 -0500
++++ vips-7.26.3/vips-7.26.pc.in        2011-10-07 22:25:21.633810254 -0500
+@@ -7,5 +7,5 @@
+ Description: Image processing library
+ Version: @VERSION@
+ Requires: @PACKAGES_USED@
+-Libs: -L${libdir} -lvips @VIPS_LIBS@ @VIPS_CXX_LIBS@
++Libs: -L${libdir} -lvips @VIPS_LIBS@
+ Cflags: -I${includedir}