projects
/
15.05
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
dae3c43
)
[include] autotools.mk: allow autogen.sh / autoreconf to fail (for now)
author
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 8 Dec 2010 01:19:52 +0000
(
01:19
+0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 8 Dec 2010 01:19:52 +0000
(
01:19
+0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24320
3c298f89
-4303-0410-b956-
a3cf2f4a3e73
include/autotools.mk
patch
|
blob
|
history
diff --git
a/include/autotools.mk
b/include/autotools.mk
index
3203604
..
df5e85a
100644
(file)
--- a/
include/autotools.mk
+++ b/
include/autotools.mk
@@
-25,10
+25,10
@@
endef
define autoreconf
(cd $(PKG_BUILD_DIR); \
if [ -x ./autogen.sh ]; then \
- ./autogen.sh; \
+ ./autogen.sh
|| true
; \
elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
$(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
- $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS); \
+ $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS)
|| true
; \
fi \
);
endef