include: make dtb argument optional in MkFIT
authorFelix Fietkau <nbd@openwrt.org>
Sun, 10 May 2015 11:46:50 +0000 (11:46 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 10 May 2015 11:46:50 +0000 (11:46 +0000)
As mkits.sh makes the -d argument optional, we'll make this same
argument optional in the MkFIT function as well.

With this change, MkFIT can be used both to generate FIT images with DT,
and without DT.

Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45660 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 788d593..a6237ff 100644 (file)
@@ -121,7 +121,7 @@ endef
 
 define Image/BuildKernel/MkFIT
        $(TOPDIR)/scripts/mkits.sh \
-               -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) -d $(3) -C $(4) -a $(5) -e $(6) \
+               -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) $(if $(3),-d $(3)) -C $(4) -a $(5) -e $(6) \
                -A $(ARCH) -v $(LINUX_VERSION)
        PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/fit-$(1).its $(KDIR)/fit-$(1)$(7).itb
 endef