kernel: bluetooth: Add dependency to kmod-crypto-ecb
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 31 May 2015 17:46:24 +0000 (17:46 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 31 May 2015 17:46:24 +0000 (17:46 +0000)
Add dependency of kmod-crypto-ecb to kmod-bluetooth to avoid the kernel warning
"Bluetooth: Unable to create crypto context".

Signed-off-by: Bruno Randolf <br1@einfach.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45860 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/other.mk

index 082c74a..955c140 100644 (file)
@@ -28,7 +28,7 @@ $(eval $(call KernelPackage,6lowpan))
 define KernelPackage/bluetooth
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Bluetooth support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-lib-crc16 +kmod-hid
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid
   KCONFIG:= \
        CONFIG_BLUEZ \
        CONFIG_BLUEZ_L2CAP \