[packages/qt4] make QMAKE_LIBS modifiable from within OpenWrt Makefiles invoking...
authormirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Feb 2011 19:56:38 +0000 (19:56 +0000)
committermirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Feb 2011 19:56:38 +0000 (19:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25489 3c298f89-4303-0410-b956-a3cf2f4a3e73

Xorg/lib/qt4/files/qmake.mk
Xorg/lib/qt4/files/qws-qmake.conf
Xorg/lib/qt4/files/x11-qmake.conf

index 8413f58..96ec2a7 100644 (file)
@@ -22,6 +22,7 @@ define Build/Configure/Qmake
        TARGET_LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)" \
        TARGET_INCDIRS="$(TARGET_INCDIRS)" \
        TARGET_LIBDIRS="$(TARGET_LIBDIRS)" \
+       TARGET_LIBS="$(TARGET_LIBS)" \
        STAGING_DIR_HOST="$(STAGING_DIR)/../host" \
        STAGING_DIR="$(STAGING_DIR)" \
        qmake \
index cec834c..5e317dc 100644 (file)
@@ -21,6 +21,7 @@ QMAKE_CFLAGS                                  = $$(TARGET_CFLAGS)
 QMAKE_CXXFLAGS                                 = $$(TARGET_CFLAGS)
 QMAKE_LINK                                             = $$(TARGET_CXX)
 QMAKE_LINK_C                                   = $$(TARGET_CC)
+QMAKE_LIBS                                             = $$(TARGET_LIBS)
 QMAKE_LFLAGS                                   = $$(TARGET_LDFLAGS) # this will end up in redundant "-L"-strings, as they're already in $QMAKE_LIBDIR_QT, however TARGET_LDFLAGS may contain not only directories but special linker options
 
 #unset vars which would intefere with vars/flags passed over by OpenWrt
index 48c7541..b5a49c5 100644 (file)
@@ -26,6 +26,7 @@ QMAKE_CFLAGS                                  = $$(TARGET_CFLAGS)
 QMAKE_CXXFLAGS                                 = $$(TARGET_CFLAGS)
 QMAKE_LINK                                     = $$(TARGET_CXX)
 QMAKE_LINK_C                                   = $$(TARGET_CC)
+QMAKE_LIBS                                             = $$(TARGET_LIBS)
 QMAKE_LFLAGS                                   = $$(TARGET_LDFLAGS) # this will end up in redundant "-L"-strings, as they're already in $QMAKE_LIBDIR_QT, however TARGET_LDFLAGS may contain not only directories but special linker options
 
 #unset vars which would intefere with vars/flags passed over by OpenWrt