ar71xx: image: improve the rootfs_align macro
authorGabor Juhos <juhosg@openwrt.org>
Sun, 22 Sep 2013 09:11:24 +0000 (09:11 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 22 Sep 2013 09:11:24 +0000 (09:11 +0000)
Improve the macro to return correct value for
all squashfs variant.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38116 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index 9871f6e..60990b2 100644 (file)
@@ -14,7 +14,7 @@ $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squ
 endef
 
 define rootfs_align
-$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs-%,0x4,$(1)))))
+$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs%,0x4,$(patsubst root.%,%,$(1))))))
 endef
 
 define sysupname