FreeSWITCH: Synced to FS latest git HEAD with some fixes and added mod_ssml.
authorMazilo <openwrt.mazilo@recursor.net>
Sat, 28 Sep 2013 15:21:29 +0000 (11:21 -0400)
committerMazilo <openwrt.mazilo@recursor.net>
Sat, 28 Sep 2013 15:21:29 +0000 (11:21 -0400)
1. Synched to FS git HEAD 6b9382290d9b6cf3ebcd8396c32a305fc0182c6b.
2. Fixed error in recursive dependency detected (Trac #: 14111)
3. Added mod_ssml.

Signed-off-by: Mazilo <openwrt.mazilo@recursor.net>
net/freeswitch/Makefile
net/freeswitch/patches/000-build-openwrt_rules.mk.patch
net/freeswitch/patches/001-build-modules_conf_in.patch
net/freeswitch/patches/100-libs-esl-Makefile.patch

index e475a96..c110984 100644 (file)
@@ -19,7 +19,7 @@ PKG_VERSION:=1.5.6b
 # http://fisheye.freeswitch.org
 #
 PKG_SOURCE_URL:=git://git.$(PKG_NAME).org/$(PKG_NAME).git
-FS_DEFAULT_HEAD:=fb238ed99779b28eeb1cc839b033ea2cf9d03212
+FS_DEFAULT_HEAD:=6b9382290d9b6cf3ebcd8396c32a305fc0182c6b
 FS_LATEST_HEAD:=$(if $(DUMP),$(FS_DEFAULT_HEAD),$(shell git ls-remote $(PKG_SOURCE_URL) HEAD | cut -f1))
 PKG_SOURCE_VERSION:=$(if $(CONFIG_FS_WITH_PULL_CURRENT),$(FS_LATEST_HEAD),$(FS_DEFAULT_HEAD))
 PKG_SOURCE_VERSION_SHORT:=$(shell echo $(PKG_SOURCE_VERSION)|cut -b -7)
@@ -146,6 +146,7 @@ FS_MOD_AVAILABLE:= \
        spidermonkey-socket \
        spidermonkey-teletone \
        spy \
+       ssml \
        stress \
        syslog \
        timerfd \
@@ -227,7 +228,7 @@ define Package/$(PKG_NAME)/config
        or send in your patches.
 
     config FS_WITH_ALSA
-    depends on PACKAGE_$(PKG_NAME) && PACKAGE_alsa-lib
+    depends on PACKAGE_$(PKG_NAME)
     bool "Enable ALSA for sound support"
     default n
     help
@@ -596,7 +597,7 @@ CONFIGURE_ARGS+= \
        --with-modinstdir="/usr/lib/$(PKG_NAME)" \
        --with-random="/dev/urandom" \
        $(if $(CONFIG_FS_WITH_MYSQL),--with,--without)-mysql \
-       $(if $(CONFIG_FS_WITH_POSTGRESQL),--with,--without)-pgsql \
+       $(if $(CONFIG_FS_WITH_POSTGRESQL),--with,--without)-pgsql-support \
        $(if $(CONFIG_FS_WITH_SQLITE3),--with,--without)-sqlite3 \
        $(call autoconf_bool,CONFIG_FS_WITH_IPV6,ipv6) \
        $(call autoconf_bool,CONFIG_FS_WITH_OPT,optimization) \
@@ -1023,7 +1024,7 @@ $(eval $(call BuildPlugin,gsmopen,GSM Modem compatible Endpoint,mod,,,alsa,+FS_W
 $(eval $(call BuildPlugin,h26x,H26X Linear Codec,vanilla,,,,))
 $(eval $(call BuildPlugin,h323,H323 Endpoint,mod,,,,@BROKEN)) # Req. H323Plus v1.24.x or newer
 $(eval $(call BuildPlugin,hash,API For Manipulating A Hash Table,vanilla,,,,))
-$(eval $(call BuildPlugin,html5,HTML5 Endpoint Module,vanilla,,,,))
+#$(eval $(call BuildPlugin,html5,HTML5 Endpoint Module,vanilla,,,,)) # defunct?
 $(eval $(call BuildPlugin,httapi,HT Telephony API and HTTP Caching,mod,,,,)) # ~/conf
 $(eval $(call BuildPlugin,http-cache,HTTP GET With Caching,mod,,,,+libcurl)) # ~/conf
 $(eval $(call BuildPlugin,ilbc,ILBC Codec,vanilla,,,,))
@@ -1087,6 +1088,7 @@ $(eval $(call BuildPlugin,spidermonkey-odbc,JavaScript ODBC,vanilla,,,,@BROKEN))
 $(eval $(call BuildPlugin,spidermonkey-socket,JavaScript Socket,vanilla,,,,@BROKEN))
 $(eval $(call BuildPlugin,spidermonkey-teletone,JavaScript Teletone,vanilla,,,,@BROKEN))
 $(eval $(call BuildPlugin,spy,User Spy,vanilla,,,,))
+$(eval $(call BuildPlugin,ssml,SSML audio rendering format,mod,,,rayo,))
 $(eval $(call BuildPlugin,stress,Voice Stress Detection,vanilla,,,,))
 $(eval $(call BuildPlugin,syslog,SysLog logger,vanilla,,,,))
 $(eval $(call BuildPlugin,timerfd,Linux Kernel timerfd API,vanilla,,,,))
index 64bfce0..31fb16f 100644 (file)
@@ -2,9 +2,9 @@
 +++ b/build/openwrt_rules.mk
 @@ -0,0 +1,7 @@
 +OPENWRT_DIR=$(shell (cd $(BASE)/../../..;pwd))
-+#STAGING_PREFIX=$(OPENWRT_DIR)/staging_dir/host
-+#STAGING_DIR=$(OPENWRT_DIR)/staging_dir/$(shell (cd $(BASE)/..;basename `pwd`))
-+#ARCH="$(shell grep CONFIG_ARCH $(OPENWRT_DIR)/.config|cut -d= -d'"' -f2)"
-+#GNU_TARGET_NAME=$(ARCH)-openwrt-linux
++STAGING_PREFIX=$(OPENWRT_DIR)/staging_dir/host
++STAGING_DIR=$(OPENWRT_DIR)/staging_dir/$(shell (cd $(BASE)/..;basename `pwd`))
++ARCH="$(shell grep CONFIG_ARCH $(OPENWRT_DIR)/.config|cut -d= -d'"' -f2)"
++GNU_TARGET_NAME=$(ARCH)-openwrt-linux
 +
 +include $(OPENWRT_DIR)/rules.mk
index 5d20600..7b57a66 100644 (file)
@@ -8,10 +8,3 @@
  #applications/mod_sonar
  applications/mod_sms
  #applications/mod_snapshot
-@@ -152,4 +153,4 @@ xml_int/mod_xml_scgi
- #../../libs/openzap/mod_openzap
- ## Experimental Modules (don't cry if they're broken)
--#../../contrib/mod/xml_int/mod_xml_odbc
-\ No newline at end of file
-+#../../contrib/mod/xml_int/mod_xml_odbc
index 6806db8..8a11714 100644 (file)
@@ -1,22 +1,9 @@
 --- a/libs/esl/Makefile
 +++ b/libs/esl/Makefile
-@@ -8,7 +8,7 @@ PICKY=-O2
- CFLAGS=$(BASE_FLAGS) $(PICKY)
- CXXFLAGS=$(BASE_FLAGS)
- MYLIB=libesl.a
--LIBS=-lncurses -lesl -lpthread -lm $(TINFO_LIBS)
-+LIBS=-L$(STAGING_DIR)/usr/lib -lncurses -lesl -lpthread -lm $(TINFO_LIBS)
- LDFLAGS=-L.
- OBJS=src/esl.o src/esl_event.o src/esl_threadmutex.o src/esl_config.o src/esl_json.o src/esl_buffer.o
- SRC=src/esl.c src/esl_json.c src/esl_event.c src/esl_threadmutex.c src/esl_config.c src/esl_oop.cpp src/esl_json.c src/esl_buffer.c
-@@ -20,8 +20,8 @@ OBJS += src/esl_oop.o
- all: $(MYLIB) fs_cli testclient testserver ivrd
- $(MYLIB): $(OBJS) $(HEADERS) $(SRC)
--      ar rcs $(MYLIB) $(OBJS)
--      ranlib $(MYLIB)
-+      $(AR) rcs $(MYLIB) $(OBJS)
-+      $(RANLIB) $(MYLIB)
- testserver: $(MYLIB) testserver.c
-       $(CC) $(CC_CFLAGS) $(CFLAGS) testserver.c -o testserver $(LDFLAGS) $(LIBS)
+@@ -1,3 +1,6 @@
++BASE=../..
++include $(BASE)/build/openwrt_rules.mk
++
+ include eslmake.rules
+ PWD=$(shell pwd)
+ INCS=-I$(PWD)/src/include