[packages_10.03.2] hplip: merge r28055, r29199, r29280
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 20:53:27 +0000 (20:53 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 20:53:27 +0000 (20:53 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30143 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/hplip/Makefile
utils/hplip/files/hplib.conf [new file with mode: 0644]

index 15e6aa7..2e8406a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hplip
 PKG_VERSION:=3.9.12
-PKG_RELEASE:=1
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/hplip
@@ -25,7 +25,7 @@ define Package/hplip
   CATEGORY:=Utilities
   TITLE:=HP Linux Imaging and Printing
   URL:=http://sourceforge.net/projects/hplip/
-  DEPENDS+=+libjpeg +sane-libs +cups +libusb
+  DEPENDS+=+libjpeg +libtiff +libusb +cups +sane-libs
 endef
 
 define Package/hplip/description
@@ -68,6 +68,13 @@ define Package/hplip/install
 
        $(INSTALL_DIR) $(1)/etc/hotplug.d/usb/
        $(INSTALL_BIN) ./files/20-hplip $(1)/etc/hotplug.d/usb/
+
+       $(INSTALL_DIR) $(1)/etc/sane.d/dll.d/
+       $(INSTALL_DATA) ./files/hplib.conf $(1)/etc/sane.d/dll.d/hplib
+endef
+
+define Package/hplip/conffiles
+/etc/hp/hplip.conf
 endef
 
 $(eval $(call BuildPackage,hplip))
diff --git a/utils/hplip/files/hplib.conf b/utils/hplip/files/hplib.conf
new file mode 100644 (file)
index 0000000..d67d370
--- /dev/null
@@ -0,0 +1,2 @@
+# Load the hplib driver
+hpaio