[packages] l2tpv3tun: fix libnl 2.0 fallout...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Feb 2011 21:13:53 +0000 (21:13 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Feb 2011 21:13:53 +0000 (21:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25655 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/l2tpv3tun/Makefile
net/l2tpv3tun/patches/100-nl_handle_alloc.patch [new file with mode: 0644]

index 0d3e71c..f965569 100644 (file)
@@ -38,7 +38,7 @@ MAKE_FLAGS += \
        CC="$(TARGET_CC)" \
        CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(LINUX_DIR)/include" \
        LD="$(TARGET_CC)" \
-       LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib -lnl"
+       LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib -lnl -lnl-genl"
 
 define Package/l2tpv3tun/install
        $(INSTALL_DIR) $(1)/usr/bin
diff --git a/net/l2tpv3tun/patches/100-nl_handle_alloc.patch b/net/l2tpv3tun/patches/100-nl_handle_alloc.patch
new file mode 100644 (file)
index 0000000..6ed2288
--- /dev/null
@@ -0,0 +1,25 @@
+Index: l2tpv3tun-0.2/main.c
+===================================================================
+--- l2tpv3tun-0.2.orig/main.c
++++ l2tpv3tun-0.2/main.c
+@@ -100,7 +100,7 @@ struct l2tp_data {
+ };
+
+ /* netlink socket */
+-static struct nl_handle *nl_sock;
++static struct nl_sock *nl_sock;
+ static int nl_family;
+
+ /*****************************************************************************
+@@ -788,9 +788,9 @@ static int do_show(int argc, char **argv
+
+ int do_ipl2tp(int argc, char **argv)
+ {
+-       nl_sock = nl_handle_alloc();
++       nl_sock = nl_socket_alloc();
+        if (!nl_sock) {
+-               perror("nl_handle_alloc");
++               perror("nl_socket_alloc");
+                return 1;
+        }
+