projects
/
15.05
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8a777e9
)
[package] fix kmod-pcmcia-serial for 3.3+ kernels
author
Florian Fainelli
<florian@openwrt.org>
Fri, 27 Apr 2012 16:44:44 +0000
(16:44 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Fri, 27 Apr 2012 16:44:44 +0000
(16:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31490
3c298f89
-4303-0410-b956-
a3cf2f4a3e73
package/kernel/modules/pcmcia.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/pcmcia.mk
b/package/kernel/modules/pcmcia.mk
index
48112b0
..
7ea2599
100644
(file)
--- a/
package/kernel/modules/pcmcia.mk
+++ b/
package/kernel/modules/pcmcia.mk
@@
-70,7
+70,11
@@
define KernelPackage/pcmcia-serial
CONFIG_PCMCIA_SERIAL_CS \
CONFIG_SERIAL_8250_CS
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
- FILES:=$(LINUX_DIR)/drivers/tty/serial/serial_cs.ko
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
+ FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/serial_cs.ko
+ else
+ FILES:=$(LINUX_DIR)/drivers/tty/serial/serial_cs.ko
+ endif
else
FILES:=$(LINUX_DIR)/drivers/serial/serial_cs.ko
endif