[package] Fix missing dependency in solos-pci module
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Sep 2010 11:18:00 +0000 (11:18 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Sep 2010 11:18:00 +0000 (11:18 +0000)
Modinfo for solos-pci tells us that it has a dependency on "atm", but this isn't
 captured in the Makefile.

Signed-off-by: Philip A. Prindeville <philipp_subx@redfish-solutions.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23086 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/netdevices.mk

index aaee3ac..61fccf4 100644 (file)
@@ -489,7 +489,7 @@ $(eval $(call KernelPackage,tulip))
 define KernelPackage/solos-pci
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Solos ADSL2+ multiport modem
-  DEPENDS:=@TARGET_x86
+  DEPENDS:=@TARGET_x86 +kmod-atm
   KCONFIG:=CONFIG_ATM_SOLOS
   FILES:=$(LINUX_DIR)/drivers/atm/solos-pci.ko
   AUTOLOAD:=$(call AutoLoad,50,solos-pci)