[package] update httping to 1.3.0 (#5552)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 Jul 2009 15:17:00 +0000 (15:17 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 Jul 2009 15:17:00 +0000 (15:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16947 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/httping/Makefile
net/httping/patches/002-version.patch

index 695a2d7..d05ef1c 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=httping
-PKG_VERSION:=1.2.6
+PKG_VERSION:=1.3.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
-PKG_MD5SUM:=2fa68b95d190a9e101232792df49e1ad
+PKG_MD5SUM:=41c912a9ecc904e51d7260053fc2195c
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -37,7 +37,7 @@ define Build/Compile
        )
 endef
 
-define Package/httping/install 
+define Package/httping/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/httping $(1)/usr/sbin/
 endef
index 11361ec..fad6c26 100644 (file)
@@ -4,12 +4,12 @@
  #include "utils.h"
  #include "error.h"
  
-+#define VERSION "1.2.6"
++#define VERSION "1.3.0"
 +
  static volatile int stop = 0;
  
  int quiet = 0;
-@@ -50,7 +52,7 @@
+@@ -50,7 +52,7 @@ char last_error[ERROR_BUFFER_SIZE];
  
  void version(void)
  {
@@ -18,7 +18,7 @@
  #ifndef NO_SSL
        fprintf(stderr, "SSL support included\n");
  #endif
-@@ -425,7 +427,7 @@
+@@ -444,7 +446,7 @@ int main(int argc, char *argv[])
        if (useragent)
                sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
        else