generic: fix relocate build with binutils 2.25.1
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 24 Jan 2016 12:36:15 +0000 (12:36 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 24 Jan 2016 12:36:15 +0000 (12:36 +0000)
The new .abiflags section was kept, pushing the appended arguments to
the wrong offset and causing it to read the section instead, making
it fail on boot.

Fix this by dropping this section as well as the other sections.

Closes #21679.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48474 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic/image/relocate/Makefile

index 5f6ebeb..19e7019 100644 (file)
@@ -29,7 +29,8 @@ LD            := $(CROSS_COMPILE)ld
 OBJCOPY                := $(CROSS_COMPILE)objcopy
 OBJDUMP                := $(CROSS_COMPILE)objdump
 
-BIN_FLAGS      := -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
+BIN_FLAGS      := -O binary -R .reginfo -R .note -R .comment -R .mdebug \
+                  -R .MIPS.abiflags -S
 
 CFLAGS         = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
                  -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \