fix rebuild of pwlib and openh323 after root_clean.
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 17 May 2006 01:07:20 +0000 (01:07 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 17 May 2006 01:07:20 +0000 (01:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3791 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/openh323/Makefile
openwrt/package/pwlib/Makefile

index a17ac00..f85e623 100644 (file)
@@ -49,6 +49,7 @@ $(PKG_BUILD_DIR)/.configured:
                        --enable-audio \
                        --disable-video \
        );
+       ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
        touch $@
 
 
@@ -58,11 +59,8 @@ $(PKG_BUILD_DIR)/.built:
                optnoshared
        touch $@
 
-install-link:
-       ln -s $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-
 uninstall-link:
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
+       rm -f $(BUILD_DIR)/$(PKG_NAME)
 
-compile-targets: $(PKG_BUILD_DIR)/.built install-link
+compile-targets: $(PKG_BUILD_DIR)/.built
 clean-targets: uninstall-link
index 66e806d..68857ff 100644 (file)
@@ -88,6 +88,7 @@ $(PKG_BUILD_DIR)/.configured:
                        --disable-wavfile \
                        --disable-xmlrpc \
        );
+       ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
@@ -96,11 +97,8 @@ $(PKG_BUILD_DIR)/.built:
                optnoshared
        touch $@
 
-install-link:
-       ln -s $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-
 uninstall-link:
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
+       rm -f $(BUILD_DIR)/$(PKG_NAME)
 
-compile-targets: $(PKG_BUILD_DIR)/.built install-link
+compile-targets: $(PKG_BUILD_DIR)/.built
 clean-targets: uninstall-link