brcm63xx: move gzip build command to include/image.mk
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 14 Aug 2015 15:10:47 +0000 (15:10 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 14 Aug 2015 15:10:47 +0000 (15:10 +0000)
Allow other targets to make use of it.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46601 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk
target/linux/brcm63xx/image/Makefile

index 56c60d6..73fc805 100644 (file)
@@ -323,6 +323,11 @@ define Build/lzma
        @mv $@.new $@
 endef
 
+define Build/gzip
+       gzip -9n -c $@ $(1) > $@.new
+       @mv $@.new $@
+endef
+
 define Build/kernel-bin
        rm -f $@
        cp $^ $@
index f15b30b..90b9fa6 100755 (executable)
@@ -38,11 +38,6 @@ define Build/append-dtb
        cat $@.dtb >> $@
 endef
 
-define Build/gzip
-       gzip -9 -c $@ > $@.gz
-       mv $@.gz $@
-endef
-
 define Build/hcs-initramfs
        $(STAGING_DIR_HOST)/bin/hcsmakeimage --magic_bytes=$(HCS_MAGIC_BYTES) \
                --rev_maj=$(HCS_REV_MAJ) --rev_min=$(HCS_REV_MIN) --input_file=$@ \