the mips -ffreestanding patch has been unnecessary for a long time now, remove it
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Mar 2010 18:48:50 +0000 (18:48 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Mar 2010 18:48:50 +0000 (18:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20149 3c298f89-4303-0410-b956-a3cf2f4a3e73

13 files changed:
target/linux/ar71xx/patches-2.6.32/001-ar71xx_core.patch
target/linux/ar71xx/patches-2.6.32/300-mips_fw_myloader.patch
target/linux/ar71xx/patches-2.6.33/001-ar71xx_core.patch
target/linux/ar71xx/patches-2.6.33/300-mips_fw_myloader.patch
target/linux/ar71xx/patches-2.6.34/001-ar71xx_core.patch
target/linux/ar71xx/patches-2.6.34/300-mips_fw_myloader.patch
target/linux/generic-2.6/patches-2.6.25/202-mips-freestanding.patch [deleted file]
target/linux/generic-2.6/patches-2.6.30/202-mips-freestanding.patch [deleted file]
target/linux/generic-2.6/patches-2.6.31/202-mips-freestanding.patch [deleted file]
target/linux/generic-2.6/patches-2.6.32/202-mips-freestanding.patch [deleted file]
target/linux/generic-2.6/patches-2.6.33/202-mips-freestanding.patch [deleted file]
target/linux/generic-2.6/patches-2.6.34/202-mips-freestanding.patch [deleted file]
target/linux/ramips/patches-2.6.32/100-mips-ralink-core.patch

index c33e902..e1a1e3e 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -624,6 +624,13 @@ else
- load-$(CONFIG_CPU_CAVIUM_OCTEON)      += 0xffffffff81100000
+@@ -156,6 +156,13 @@ ifeq (,$(findstring march=octeon, $(cfla
+ cflags-$(CONFIG_CPU_CAVIUM_OCTEON) += -Wa,-march=octeon
  endif
  
 +#
@@ -11,9 +11,9 @@
 +cflags-$(CONFIG_ATHEROS_AR71XX)       += -I$(srctree)/arch/mips/include/asm/mach-ar71xx
 +load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
 +
- # temporary until string.h is fixed
- cflags-y += -ffreestanding
+ cflags-$(CONFIG_CPU_R4000_WORKAROUNDS)        += $(call cc-option,-mfix-r4000,)
+ cflags-$(CONFIG_CPU_R4400_WORKAROUNDS)        += $(call cc-option,-mfix-r4400,)
+ cflags-$(CONFIG_CPU_DADDI_WORKAROUNDS)        += $(call cc-option,-mno-daddi,)
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
 @@ -43,6 +43,23 @@ config AR7
index 8a83460..7eb150e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -169,6 +169,7 @@ endif
+@@ -178,6 +178,7 @@ endif
  #
  libs-$(CONFIG_ARC)            += arch/mips/fw/arc/
  libs-$(CONFIG_CFE)            += arch/mips/fw/cfe/
index 5b322d6..5073652 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -637,6 +637,13 @@ else
- load-$(CONFIG_CPU_CAVIUM_OCTEON)      += 0xffffffff81100000
+@@ -166,6 +166,13 @@ ifeq (,$(findstring march=octeon, $(cfla
+ cflags-$(CONFIG_CPU_CAVIUM_OCTEON) += -Wa,-march=octeon
  endif
  
 +#
@@ -11,9 +11,9 @@
 +cflags-$(CONFIG_ATHEROS_AR71XX)       += -I$(srctree)/arch/mips/include/asm/mach-ar71xx
 +load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
 +
- # temporary until string.h is fixed
- cflags-y += -ffreestanding
+ cflags-$(CONFIG_CPU_R4000_WORKAROUNDS)        += $(call cc-option,-mfix-r4000,)
+ cflags-$(CONFIG_CPU_R4400_WORKAROUNDS)        += $(call cc-option,-mfix-r4400,)
+ cflags-$(CONFIG_CPU_DADDI_WORKAROUNDS)        += $(call cc-option,-mno-daddi,)
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
 @@ -48,6 +48,23 @@ config AR7
index dd4905a..0d8f132 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -181,6 +181,7 @@ endif
+@@ -188,6 +188,7 @@ endif
  #
  libs-$(CONFIG_ARC)            += arch/mips/fw/arc/
  libs-$(CONFIG_CFE)            += arch/mips/fw/cfe/
index 5b322d6..5073652 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -637,6 +637,13 @@ else
- load-$(CONFIG_CPU_CAVIUM_OCTEON)      += 0xffffffff81100000
+@@ -166,6 +166,13 @@ ifeq (,$(findstring march=octeon, $(cfla
+ cflags-$(CONFIG_CPU_CAVIUM_OCTEON) += -Wa,-march=octeon
  endif
  
 +#
@@ -11,9 +11,9 @@
 +cflags-$(CONFIG_ATHEROS_AR71XX)       += -I$(srctree)/arch/mips/include/asm/mach-ar71xx
 +load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
 +
- # temporary until string.h is fixed
- cflags-y += -ffreestanding
+ cflags-$(CONFIG_CPU_R4000_WORKAROUNDS)        += $(call cc-option,-mfix-r4000,)
+ cflags-$(CONFIG_CPU_R4400_WORKAROUNDS)        += $(call cc-option,-mfix-r4400,)
+ cflags-$(CONFIG_CPU_DADDI_WORKAROUNDS)        += $(call cc-option,-mno-daddi,)
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
 @@ -48,6 +48,23 @@ config AR7
index dd4905a..0d8f132 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -181,6 +181,7 @@ endif
+@@ -188,6 +188,7 @@ endif
  #
  libs-$(CONFIG_ARC)            += arch/mips/fw/arc/
  libs-$(CONFIG_CFE)            += arch/mips/fw/cfe/
diff --git a/target/linux/generic-2.6/patches-2.6.25/202-mips-freestanding.patch b/target/linux/generic-2.6/patches-2.6.25/202-mips-freestanding.patch
deleted file mode 100644 (file)
index e4cdfdd..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -593,6 +593,9 @@ core-$(CONFIG_TOSHIBA_RBTX4938) += arch/
- cflags-$(CONFIG_TOSHIBA_RBTX4938) += -Iinclude/asm-mips/mach-tx49xx
- load-$(CONFIG_TOSHIBA_RBTX4938) += 0xffffffff80100000
-+# temporary until string.h is fixed
-+cflags-y += -ffreestanding
-+
- cflags-y                      += -Iinclude/asm-mips/mach-generic
- drivers-$(CONFIG_PCI)         += arch/mips/pci/
diff --git a/target/linux/generic-2.6/patches-2.6.30/202-mips-freestanding.patch b/target/linux/generic-2.6/patches-2.6.30/202-mips-freestanding.patch
deleted file mode 100644 (file)
index 5e114a9..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -607,6 +607,9 @@ ifdef CONFIG_PHYSICAL_START
- load-y                        = $(CONFIG_PHYSICAL_START)
- endif
-+# temporary until string.h is fixed
-+cflags-y += -ffreestanding
-+
- cflags-y                      += -I$(srctree)/arch/mips/include/asm/mach-generic
- drivers-$(CONFIG_PCI)         += arch/mips/pci/
diff --git a/target/linux/generic-2.6/patches-2.6.31/202-mips-freestanding.patch b/target/linux/generic-2.6/patches-2.6.31/202-mips-freestanding.patch
deleted file mode 100644 (file)
index 021d072..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -612,6 +612,9 @@ else
- load-$(CONFIG_CPU_CAVIUM_OCTEON)      += 0xffffffff81100000
- endif
-+# temporary until string.h is fixed
-+cflags-y += -ffreestanding
-+
- cflags-y                      += -I$(srctree)/arch/mips/include/asm/mach-generic
- drivers-$(CONFIG_PCI)         += arch/mips/pci/
diff --git a/target/linux/generic-2.6/patches-2.6.32/202-mips-freestanding.patch b/target/linux/generic-2.6/patches-2.6.32/202-mips-freestanding.patch
deleted file mode 100644 (file)
index 0c6d585..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -624,6 +624,9 @@ else
- load-$(CONFIG_CPU_CAVIUM_OCTEON)      += 0xffffffff81100000
- endif
-+# temporary until string.h is fixed
-+cflags-y += -ffreestanding
-+
- cflags-y                      += -I$(srctree)/arch/mips/include/asm/mach-generic
- drivers-$(CONFIG_PCI)         += arch/mips/pci/
diff --git a/target/linux/generic-2.6/patches-2.6.33/202-mips-freestanding.patch b/target/linux/generic-2.6/patches-2.6.33/202-mips-freestanding.patch
deleted file mode 100644 (file)
index f8511fd..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -637,6 +637,9 @@ else
- load-$(CONFIG_CPU_CAVIUM_OCTEON)      += 0xffffffff81100000
- endif
-+# temporary until string.h is fixed
-+cflags-y += -ffreestanding
-+
- cflags-y                      += -I$(srctree)/arch/mips/include/asm/mach-generic
- drivers-$(CONFIG_PCI)         += arch/mips/pci/
diff --git a/target/linux/generic-2.6/patches-2.6.34/202-mips-freestanding.patch b/target/linux/generic-2.6/patches-2.6.34/202-mips-freestanding.patch
deleted file mode 100644 (file)
index f8511fd..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -637,6 +637,9 @@ else
- load-$(CONFIG_CPU_CAVIUM_OCTEON)      += 0xffffffff81100000
- endif
-+# temporary until string.h is fixed
-+cflags-y += -ffreestanding
-+
- cflags-y                      += -I$(srctree)/arch/mips/include/asm/mach-generic
- drivers-$(CONFIG_PCI)         += arch/mips/pci/
index 5bf5f34..10d329c 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -624,6 +624,26 @@ else
- load-$(CONFIG_CPU_CAVIUM_OCTEON)      += 0xffffffff81100000
+@@ -156,6 +156,26 @@ ifeq (,$(findstring march=octeon, $(cfla
+ cflags-$(CONFIG_CPU_CAVIUM_OCTEON) += -Wa,-march=octeon
  endif
  
 +#
@@ -24,9 +24,9 @@
 +cflags-$(CONFIG_RALINK_RT305X)        += -I$(srctree)/arch/mips/include/asm/mach-ralink/rt305x
 +load-$(CONFIG_RALINK_RT305X)  += 0xffffffff80000000
 +
- # temporary until string.h is fixed
- cflags-y += -ffreestanding
+ cflags-$(CONFIG_CPU_R4000_WORKAROUNDS)        += $(call cc-option,-mfix-r4000,)
+ cflags-$(CONFIG_CPU_R4400_WORKAROUNDS)        += $(call cc-option,-mfix-r4400,)
+ cflags-$(CONFIG_CPU_DADDI_WORKAROUNDS)        += $(call cc-option,-mno-daddi,)
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
 @@ -43,6 +43,9 @@ config AR7