ubus: fix various ACL processing problems
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Dec 2015 19:42:00 +0000 (19:42 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Dec 2015 19:42:00 +0000 (19:42 +0000)
Bump ubus to current Git HEAD in order to:

 * Fix a null pointer access when user ACLs are loaded into memory
 * Fix wrong permission handling for uid=0, gid!=0 peers
 * Fix return code for permission defined cases
 * Fix socket error handling when the server connection dies
 * Make ACL file path configurable
 * Remove invalid usages of poll() when using a zero timeout

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47816 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/system/ubus/Makefile

index 3e09191..b943433 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ubus
-PKG_VERSION:=2015-11-19
+PKG_VERSION:=2015-12-09
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=http://git.openwrt.org/project/ubus.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=259450f414d8c9ee41896e8e6d6bc57ec00e2b63
+PKG_SOURCE_VERSION:=766d49876f8f877f4846c16864e7f73b5a3917f7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MIRROR_MD5SUM:=
 CMAKE_INSTALL:=1