kernel: crypto-aead depends on crypto-null in 4.3 as well
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Dec 2015 19:21:49 +0000 (19:21 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Dec 2015 19:21:49 +0000 (19:21 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47870 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/crypto.mk

index fe64db4..dc817ee 100644 (file)
@@ -27,7 +27,7 @@ define KernelPackage/crypto-aead
        CONFIG_CRYPTO_AEAD2
   FILES:=$(LINUX_DIR)/crypto/aead.ko
   AUTOLOAD:=$(call AutoLoad,09,aead,1)
-  $(call AddDepends/crypto, +LINUX_4_4:kmod-crypto-null)
+  $(call AddDepends/crypto, +LINUX_4_3:kmod-crypto-null +LINUX_4_4:kmod-crypto-null)
 endef
 
 $(eval $(call KernelPackage,crypto-aead))