scripts: extend rstrip.sh to remove bad rpaths
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Feb 2015 15:48:48 +0000 (15:48 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Feb 2015 15:48:48 +0000 (15:48 +0000)
Remove all rpath entries which do not point to a location below /lib or
/usr/lib and which do not begin with '$ORIGIN'.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44377 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk
scripts/rstrip.sh

index 949bfb2..a79e20d 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -269,6 +269,7 @@ else
     NM="$(TARGET_CROSS)nm" \
     STRIP="$(STRIP)" \
     STRIP_KMOD="$(SCRIPT_DIR)/strip-kmod.sh" \
+    PATCHELF="$(STAGING_DIR_HOST)/bin/patchelf" \
     $(SCRIPT_DIR)/rstrip.sh
 endif
 
index 4665ff5..4e4232d 100755 (executable)
@@ -25,11 +25,21 @@ find $TARGETS -type f -a -exec file {} \; | \
 (
   IFS=":"
   while read F S; do
-    echo "$SELF: $F:$S"
+    echo "$SELF: $F: $S"
        [ "${S}" = "relocatable" ] && {
                eval "$STRIP_KMOD $F"
        } || {
                b=$(stat -c '%a' $F)
+               [ -z "$PATCHELF" ] || [ -z "$TOPDIR" ] || {
+                       old_rpath="$($PATCHELF --print-rpath $F)"; new_rpath=""
+                       for path in $old_rpath; do
+                               case "$path" in
+                                       /lib/[^/]*|/usr/lib/[^/]*|\$ORIGIN/*) new_rpath="${new_rpath:+$new_rpath:}$path" ;;
+                                       *) echo "$SELF: $F: removing rpath $path" ;;
+                               esac
+                       done
+                       [ "$new_rpath" = "$old_rpath" ] || $PATCHELF --set-rpath "$new_rpath" $F
+               }
                eval "$STRIP $F"
                a=$(stat -c '%a' $F)
                [ "$a" = "$b" ] || chmod $b $F