targets: remove useless quotes around KERNELNAME
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Oct 2014 20:17:19 +0000 (20:17 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Oct 2014 20:17:19 +0000 (20:17 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42780 3c298f89-4303-0410-b956-a3cf2f4a3e73

26 files changed:
target/linux/avr32/Makefile
target/linux/bcm53xx/Makefile
target/linux/brcm2708/Makefile
target/linux/cns21xx/Makefile
target/linux/cns3xxx/Makefile
target/linux/ep93xx/Makefile
target/linux/gemini/Makefile
target/linux/imx6/Makefile
target/linux/iop32x/Makefile
target/linux/ipq806x/Makefile
target/linux/ixp4xx/Makefile
target/linux/kirkwood/Makefile
target/linux/mcs814x/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/mvebu/Makefile
target/linux/mxs/Makefile
target/linux/omap/Makefile
target/linux/omap24xx/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/pxa/Makefile
target/linux/realview/Makefile
target/linux/realview/image/Makefile
target/linux/sunxi/Makefile

index de54103..cd8bd5e 100644 (file)
@@ -20,6 +20,6 @@ define Target/Description
   Build firmware images for ATNGW100 board
 endef
 
-KERNELNAME:="uImage"
+KERNELNAME:=uImage
 
 $(eval $(call BuildTarget))
index 519b5a5..69f30f8 100644 (file)
@@ -22,7 +22,7 @@ define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 DEFAULT_PACKAGES += swconfig wpad-mini nvram \
        kmod-gpio-button-hotplug \
index 0779e61..c8a5536 100644 (file)
@@ -25,6 +25,6 @@ define Target/Description
        Currently produces SD Card image for Raspberry Pi.
 endef
 
-KERNELNAME="Image"
+KERNELNAME:=Image
 
 $(eval $(call BuildTarget))
index 4f320b2..a183a21 100644 (file)
@@ -24,6 +24,6 @@ define Target/Description
  Build firmware images for Cavium Networks CNS21XX based boards.
 endef
 
-KERNELNAME:="zImage uImage"
+KERNELNAME:=zImage uImage
 
 $(eval $(call BuildTarget))
index 7508240..dd5349c 100644 (file)
@@ -23,7 +23,7 @@ define Target/Description
        eg. the Gateworks Laguna family
 endef
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
 
index debb8e9..ad7fb31 100644 (file)
@@ -19,6 +19,6 @@ DEVICE_TYPE:=developerboard
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:=uImage
 
 $(eval $(call BuildTarget))
index 6a6c0a7..45ae97e 100644 (file)
@@ -15,7 +15,7 @@ MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.10.49
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
index 1e64fd7..c29187c 100644 (file)
@@ -18,6 +18,6 @@ LINUX_VERSION:=3.14.18
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 $(eval $(call BuildTarget))
index 8c66387..02037d9 100644 (file)
@@ -16,6 +16,6 @@ LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))
index 6207c91..55a0d72 100644 (file)
@@ -11,7 +11,7 @@ MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 LINUX_VERSION:=3.14.18
 
-KERNELNAME="Image dtbs"
+KERNELNAME:=Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 
index b0665db..2b249dc 100644 (file)
@@ -18,6 +18,6 @@ LINUX_VERSION:=3.10.49
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += ixp4xx-microcode fconfig
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))
index 33c33a4..4b6d841 100644 (file)
@@ -17,6 +17,6 @@ LINUX_VERSION:=3.14.18
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 $(eval $(call BuildTarget))
index 6b1b40e..25c778a 100644 (file)
@@ -26,6 +26,6 @@ DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES)) \
                  kmod-nls-utf8 \
                  kmod-mcs814x-wdt kmod-ledtrig-usbdev
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 $(eval $(call BuildTarget))
index a965773..56f655a 100644 (file)
@@ -20,6 +20,6 @@ define Target/Description
        Build images for the Freescale MPC52xx based boards.
 endef
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))
index 915faec..806b8f6 100644 (file)
@@ -23,6 +23,6 @@ define Target/Description
        Build firmware images for Freescale MPC83xx based boards (eg. RouterBoard 600).
 endef
 
-KERNELNAME:="uImage dtbImage.rb600 dtbImage.rb333"
+KERNELNAME:=uImage dtbImage.rb600 dtbImage.rb333
 
 $(eval $(call BuildTarget))
index b899d63..dc61e7c 100644 (file)
@@ -18,7 +18,7 @@ LINUX_VERSION:=3.14.18
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 DEFAULT_PACKAGES += uboot-envtools
 
index 7a5730b..9f95095 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=arm926ej-s
 
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 LINUX_VERSION:=3.14.18
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 define Target/Description
        Support for Freescale i.MX23/i.MX28 boards
index 5795c00..3ebfccd 100644 (file)
@@ -17,7 +17,7 @@ LINUX_VERSION:=3.13.7
 
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
 include $(INCLUDE_DIR)/target.mk
 
index f8cd3c5..40ad342 100644 (file)
@@ -19,7 +19,7 @@ define Target/Description
        TI OMAP-24xx
 endef
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
index a38b74f..ec40a00 100644 (file)
@@ -16,7 +16,7 @@ LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 DEFAULT_PACKAGES += kmod-ath9k kmod-crypto-mv-cesa wpad-mini kmod-i2c-core kmod-i2c-mv64xxx kmod-rtc-isl1208
 
index 817abc7..00e8d43 100644 (file)
@@ -21,6 +21,6 @@ define Target/Description
        Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
-KERNELNAME:="uImage cuImage.magicbox cuImage.openrb"
+KERNELNAME:=uImage cuImage.magicbox cuImage.openrb
 
 $(eval $(call BuildTarget))
index f6d9327..5c2e15d 100644 (file)
@@ -23,6 +23,6 @@ define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
-KERNELNAME:="uImage cuImage.taishan"
+KERNELNAME:=uImage cuImage.taishan
 
 $(eval $(call BuildTarget))
index 86e4950..c61231d 100644 (file)
@@ -20,6 +20,6 @@ define Target/Description
        Build images for PXA2xx systems, eg. Gumstix.
 endef
 
-KERNELNAME:="uImage"
+KERNELNAME:=uImage
 
 $(eval $(call BuildTarget))
index 3d49605..8089207 100644 (file)
@@ -24,6 +24,6 @@ define Target/Description
        Build images for ARM Ltd. Realview boards to be run with qemu
 endef
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))
index c6ff8ce..1f3fa4a 100644 (file)
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/BuildKernel
-       cp $(KDIR)/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+       cp $(KDIR)/$(KERNELNAME) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
 endef
 
 define Image/BuildKernel/Initramfs
-       cp $(KDIR)/$(subst ",,$(KERNELNAME))-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
+       cp $(KDIR)/$(KERNELNAME)-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
 endef
 
 define Image/Build/squashfs
index 4f59f3e..e96f081 100644 (file)
@@ -16,7 +16,7 @@ CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
 LINUX_VERSION:=3.14.18
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 DEFAULT_PACKAGES += uboot-envtools uboot-sunxi kmod-eeprom-sunxi kmod-wdt-sunxi
 
 # A10: Cortex-A8