[openssl] add safethread
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 24 Aug 2012 09:58:42 +0000 (09:58 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 24 Aug 2012 09:58:42 +0000 (09:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33269 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/openssl/Makefile

index d95783a..2962c07 100644 (file)
@@ -105,7 +105,7 @@ define Build/Configure
        )
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -DOPENSSL_THREADS -pthread -D_REENTRANT -D_THREAD_SAFE -D_THREADSAFE
 
 define Build/Compile
        # XXX: OpenSSL "make depend" will look for installed headers before its own,