point ntpd at the proper location of nlist.h
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 30 Dec 2007 16:40:42 +0000 (16:40 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 30 Dec 2007 16:40:42 +0000 (16:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10056 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/ntpd/Makefile

index 8faaf53..980b54c 100644 (file)
@@ -17,6 +17,7 @@ PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/
 PKG_MD5SUM:=fcb32a01e1ae3f9ed5bac86b12c7a1cc
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DEPENDS:=libelf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -43,6 +44,8 @@ echo "ntp             123/udp     # Network Time Protocol
 ntp             123/tcp     # Network Time Protocol" >> $${IPKG_INSTROOT}/etc/services
 endef
 
+TARGET_CPPFLAGS += -I$(STAGING_DIR)/usr/include/libelf
+
 define Build/Configure
        $(call Build/Configure/Default, \
                 --disable-all-clocks \