package/kernel: add kmod-lib-lzo
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Oct 2011 13:11:12 +0000 (13:11 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Oct 2011 13:11:12 +0000 (13:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28654 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/lib.mk

index 4b9eed4..6e80556 100644 (file)
@@ -83,6 +83,25 @@ endef
 $(eval $(call KernelPackage,libcrc32c))
 
 
+define KernelPackage/lib-lzo
+  SUBMENU:=$(LIB_MENU)
+  TITLE:=LZO library support
+  KCONFIG:= \
+       CONFIG_LZO_COMPRESS \
+       CONFIG_LZO_DECOMPRESS
+  FILES:= \
+       $(LINUX_DIR)/lib/lzo/lzo_compress.ko \
+       $(LINUX_DIR)/lib/lzo/lzo_decompress.ko
+  AUTOLOAD:=$(call AutoLoad,20, lzo_compress lzo_decompress,1)
+endef
+
+define KernelPackage/lib-lzo/description
+ Kernel module for LZO compression/decompression support
+endef
+
+$(eval $(call KernelPackage,lib-lzo))
+
+
 define KernelPackage/textsearch
 SUBMENU:=$(LIB_MENU)
   TITLE:=Textsearch support is selected if needed