build: optimize printing of disabled packages
authorFelix Fietkau <nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:07 +0000 (08:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:07 +0000 (08:57 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43015 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package-ipkg.mk

index a4901b5..ccba046 100644 (file)
@@ -102,9 +102,7 @@ ifeq ($(DUMP),)
                        echo "$(1)" >> $(PKG_INSTALL_STAMP)
         endif
       else
-        compile: $(1)-disabled
-        $(1)-disabled:
-               @echo "WARNING: skipping $(1) -- package not selected" >&2
+        $$(info WARNING: skipping $(1) -- package not selected)
       endif
     endif
     endif