package/mac80211: fix a possible NULL pointer dereference in rt2x00
authorGabor Juhos <juhosg@openwrt.org>
Thu, 16 Feb 2012 17:14:34 +0000 (17:14 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 16 Feb 2012 17:14:34 +0000 (17:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30586 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mac80211/Makefile
package/mac80211/patches/607-rt2x00-dont-try-to-destroy-unallocated-workqueue.patch [new file with mode: 0644]

index 1ab9dc2..13727d1 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=mac80211
 
 PKG_VERSION:=2012-02-06
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
 PKG_MD5SUM:=fae71c35ee3f3de6329f2db7aed6d265
 
diff --git a/package/mac80211/patches/607-rt2x00-dont-try-to-destroy-unallocated-workqueue.patch b/package/mac80211/patches/607-rt2x00-dont-try-to-destroy-unallocated-workqueue.patch
new file mode 100644 (file)
index 0000000..f9d3ca1
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/drivers/net/wireless/rt2x00/rt2x00dev.c
++++ b/drivers/net/wireless/rt2x00/rt2x00dev.c
+@@ -1224,7 +1224,8 @@ void rt2x00lib_remove_dev(struct rt2x00_
+               cancel_work_sync(&rt2x00dev->rxdone_work);
+               cancel_work_sync(&rt2x00dev->txdone_work);
+       }
+-      destroy_workqueue(rt2x00dev->workqueue);
++      if (rt2x00dev->workqueue)
++              destroy_workqueue(rt2x00dev->workqueue);
+       /*
+        * Free the tx status fifo.