dump1090: moved to github
[packages.git] / utils / lilo / Makefile
index 77a45b7..35f6da5 100644 (file)
@@ -1,29 +1,26 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4091 2006-06-27 00:35:46Z mbm $
-#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lilo
-PKG_VERSION:=22.7.3
-PKG_RELEASE:=1
+PKG_VERSION:=22.8
+PKG_RELEASE:=2
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).src.tar.gz
 PKG_SOURCE_URL:=ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/
-PKG_MD5SUM:=
-PKG_CAT:=zcat
+PKG_MD5SUM:=72765f2aafd20e23ecf07ebd22baeec7
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lilo
   SECTION:=base
   CATEGORY:=Boot Loaders
-  DEPENDS:=@LINUX_2_6_X86||LINUX_2_4_X86
+  DEPENDS:=@TARGET_x86
   TITLE:=lilo
   URL:=ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/
 endef
@@ -33,16 +30,24 @@ define Package/lilo/conffiles
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) alles
-       $(STRIP) $(PKG_BUILD_DIR)/lilo.static
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(HOSTCC) -m32" \
+               alles
 endef
 
 define Package/lilo/install
-       install -d -m0755 $(1)/sbin
+       $(INSTALL_DIR) $(1)/sbin
        $(CP) $(PKG_BUILD_DIR)/lilo.static $(1)/sbin/lilo
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) ./files/lilo.conf $(1)/etc/
        $(CP) ./files/boot.msg $(1)/etc/
 endef
 
+$(foreach command, as86 ld86, \
+  $(eval $(call RequireCommand,$(command), \
+   $(PKG_NAME) requires $(command). \
+  )) \
+)
+
 $(eval $(call BuildPackage,lilo))
+