[tools] use HOST_STATIC_LINKING instead of hardcoding -static
[openwrt.git] / tools / xz / Makefile
index 36644cd..b1698be 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,16 +7,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xz
-PKG_VERSION:=5.0.1
+PKG_VERSION:=5.0.3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://tukaani.org/xz
-PKG_MD5SUM:=cb6c7a58cec4d663a395c54d186ca0c6
+PKG_MD5SUM:=8d900b742b94fa9e708ca4f5a4b29003
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
 define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
+       $(MAKE) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat" \
+               AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
 endef
 
 $(eval $(call HostBuild))