add mklibs (based on a patch by florian) in preparation for optional library symbol...
[openwrt.git] / tools / mklibs / Makefile
diff --git a/tools/mklibs/Makefile b/tools/mklibs/Makefile
new file mode 100644 (file)
index 0000000..5053224
--- /dev/null
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mklibs
+PKG_VERSION:=0.1.26
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/m/mklibs/
+PKG_MD5SUM:=708f284975f1b567b817d27f7677a95f
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CFLAGS += -I$(CURDIR)/include
+
+define Host/Install
+       $(INSTALL_BIN) \
+               $(HOST_BUILD_DIR)/src/mklibs.py \
+               $(HOST_BUILD_DIR)/src/mklibs-copy.py \
+               $(HOST_BUILD_DIR)/src/mklibs-readelf/mklibs-readelf \
+               $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/mklibs*
+endef
+
+$(eval $(call HostBuild))