generic-2.6: update patches-2.6.35/080-mtd_plat_nand_chip_fixup.patch
[openwrt.git] / tools / gmp / Makefile
index 4c6fac4..f375ada 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009 -2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,36 +7,34 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=4.2.4
+PKG_VERSION:=4.3.2
 
 PKG_SOURCE_URL:=@GNU/gmp/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=
+PKG_MD5SUM:=dd60683d7057917e34630b4a787932e8
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-       ./configure \
-         --prefix=$(STAGING_DIR_HOST) \
-         --build=$(GNU_HOST_NAME) \
-         --enable-static \
-         --disable-shared \
-         --enable-cxx \
-         --enable-mpbsd \
-       );
-endef
+unexport CFLAGS
 
-define Host/Compile
-       make -C $(HOST_BUILD_DIR) all
-endef
+ifeq ($(HOST_OS),Darwin)
+  GNU_HOST_NAME:=
+  HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
+endif
 
-define Host/Install
-       make -C $(HOST_BUILD_DIR) install
-endef
+HOST_CONFIGURE_ARGS += \
+       --enable-static \
+       --disable-shared \
+       --enable-cxx \
+       --enable-mpbsd
 
-define Host/Clean
-       rm -rf $(HOST_BUILD_DIR)
+define Host/Configure
+       (cd $(HOST_BUILD_DIR)/$(3); \
+               $(HOST_CONFIGURE_CMD) \
+               $(HOST_CONFIGURE_VARS) \
+               $(HOST_CONFIGURE_ARGS); \
+       )
 endef
 
+
 $(eval $(call HostBuild))