[tools] use HOST_STATIC_LINKING instead of hardcoding -static
[15.05/openwrt.git] / tools / e2fsprogs / Makefile
index dc4dc70..665ca0d 100644 (file)
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:=@SF/e2fsprogs
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CFLAGS += $(FPIC)
-HOST_LDFLAGS += -static
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 
 HOST_CONFIGURE_ARGS += \
        --disable-shared \