strip trailing / from download urls
[15.05/openwrt.git] / target / utils / Makefile
index fe35475..d11d744 100644 (file)
@@ -1,9 +1,16 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
 
-TARGETS := addpattern trx motorola-bin dgfirmware
+TARGETS := addpattern trx motorola-bin dgfirmware trx2usr
 
 UTILS_BUILD_DIR:=$(BUILD_DIR)/target-utils
 
+download:
 prepare: $(UTILS_BUILD_DIR)
 compile: prepare $(patsubst %,$(UTILS_BUILD_DIR)/%,$(TARGETS)) FORCE
        mkdir -p $(STAGING_DIR)/bin
@@ -20,6 +27,6 @@ $(UTILS_BUILD_DIR):
        mkdir -p $(UTILS_BUILD_DIR)
        
 $(UTILS_BUILD_DIR)/%: src/%.c
-       $(CC) -o $@ $(patsubst $(UTILS_BUILD_DIR)/%,src/%.c,$@)
+       $(CC) -O2 -I $(STAGING_DIR)/include-host -include endian.h -o $@ $(patsubst $(UTILS_BUILD_DIR)/%,src/%.c,$@)
        chmod 755 $@