x86: remove linux 3.8 support
[openwrt.git] / target / linux / x86 / patches-3.8 / 011-tune_lzma_options.patch
diff --git a/target/linux/x86/patches-3.8/011-tune_lzma_options.patch b/target/linux/x86/patches-3.8/011-tune_lzma_options.patch
deleted file mode 100644 (file)
index c1c6004..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/scripts/Makefile.lib
-+++ b/scripts/Makefile.lib
-@@ -299,7 +299,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
- quiet_cmd_lzma = LZMA    $@
- cmd_lzma = (cat $(filter-out FORCE,$^) | \
--      lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
-+      lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
-       (rm -f $@ ; false)
- quiet_cmd_lzo = LZO     $@
---- a/arch/x86/include/asm/boot.h
-+++ b/arch/x86/include/asm/boot.h
-@@ -23,7 +23,7 @@
- #error "Invalid value for CONFIG_PHYSICAL_ALIGN"
- #endif
--#ifdef CONFIG_KERNEL_BZIP2
-+#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
- #define BOOT_HEAP_SIZE             0x400000
- #else /* !CONFIG_KERNEL_BZIP2 */