make the rest of the structure for the targets that dont have profiles yet
[openwrt.git] / target / linux / uml-2.6 / Makefile
index ff2297f..089ef58 100644 (file)
@@ -5,14 +5,29 @@
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host.mk
 
-ARCH:=i386
+# UML only makes sense on linux
+ifeq ($(HOST_OS),Linux)
+
+ARCH:=$(shell uname -m | sed \
+       -e 's/i[3-9]86/i386/' \
+       -e 's/mipsel/mips/' \
+       -e 's/mipseb/mips/' \
+       -e 's/powerpc/ppc/' \
+       -e 's/sh[234]/sh/' \
+       -e 's/armeb/arm/' \
+)
 BOARD:=uml
 BOARDNAME:=User Mode Linux
-
-LINUX_VERSION:=2.6.19.1
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=2ab08fdfddc00e09b3d5bc7397d3c8be
+FEATURES:=broken
+LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
+endif
+
 $(eval $(call BuildKernel))