kernel/generic: remove some left-over garbage from ledtrig patch
[openwrt.git] / target / linux / sibyte / Makefile
index aa8acea..a98b170 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=sibyte
-BOARDNAME:=SiByte MIPS
-FEATURES:=broken
+BOARDNAME:=Broadcom/SiByte SB-1
+FEATURES:=fpu ramdisk broken
+CPU_TYPE:=sb1
+CPU_CFLAGS_sb1:=-march=sb1
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.21.5
+KERNEL_PATCHVER:=3.3
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
+define Target/Description
+       Build firmware images for Broadcom/SiByte SB-1 boards
+endef
 
 $(eval $(call BuildTarget))