ramips: use correct key code for the RFKILL switch on the TEW-691GR
[openwrt.git] / target / linux / s3c24xx / Makefile
index 27a658c..f27bab2 100644 (file)
@@ -9,15 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=s3c24xx
 BOARDNAME:=Samsung S3C24xx
-FEATURES:=jffs2
-CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -funit-at-a-time
+FEATURES:=jffs2 broken
+CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -fno-caller-saves
+SUBTARGETS:=openmoko-gta02
 
-LINUX_VERSION:=2.6.30.2
+LINUX_VERSION:=2.6.30.10
 
 DEVICE_TYPE=phone
 
 define Target/Description
-       OpenMoko gta02
+       S3C24xx arm
 endef
 
 include $(INCLUDE_DIR)/target.mk