Update rdc to .21, mark it as broken
[openwrt.git] / target / linux / rdc-2.6 / patches / 000-rdc_fixes.patch
index 5f2db00..148fc48 100644 (file)
@@ -8,7 +8,7 @@ diff -urN linux-2.6.19/arch/i386/Kconfig linux-2.6.19.new/arch/i386/Kconfig
 +config X86_RDC
 +      bool "Support for RDC 3211 boards"
 +      help
-+        Support for RDC 3211 sustems. Say 'Y' here if the kernel is 
++        Support for RDC 3211 systems. Say 'Y' here if the kernel is 
 +        supposed to run on an IA-32 RDC R3211 system.
 +        Only choose this option if you have such as system, otherwise you
 +        should say N here.
@@ -26,23 +26,10 @@ diff -urN linux-2.6.19/arch/i386/Makefile linux-2.6.19.new/arch/i386/Makefile
 +# RDC subarch support
 +mflags-$(CONFIG_X86_RDC)      := -Iinclude/asm-i386/mach-generic
 +mcore-$(CONFIG_X86_RDC)               := mach-default
-+core-$(CONFIG_X86_RDC)                := arch/i386/mach-rdc/
++core-$(CONFIG_X86_RDC)                += arch/i386/mach-rdc/
  
  # default subarch .h files
  mflags-y += -Iinclude/asm-i386/mach-default
-diff -urN linux-2.6.19/arch/i386/kernel/time.c linux-2.6.19.new/arch/i386/kernel/time.c
---- linux-2.6.19/arch/i386/kernel/time.c       2006-11-29 22:57:37.000000000 +0100
-+++ linux-2.6.19.new/arch/i386/kernel/time.c   2006-12-17 17:13:10.000000000 +0100
-@@ -361,7 +361,8 @@
- static void __init hpet_time_init(void)
- {
-       struct timespec ts;
--      ts.tv_sec = get_cmos_time();
-+      /* RDC board does not have CMOS */
-+      ts.tv_sec = 0;
-       ts.tv_nsec = (INITIAL_JIFFIES % HZ) * (NSEC_PER_SEC / HZ);
-       do_settimeofday(&ts);
 diff -urN linux-2.6.19/arch/i386/mach-rdc/Makefile linux-2.6.19.new/arch/i386/mach-rdc/Makefile
 --- linux-2.6.19/arch/i386/mach-rdc/Makefile   1970-01-01 01:00:00.000000000 +0100
 +++ linux-2.6.19.new/arch/i386/mach-rdc/Makefile       2006-12-17 17:13:33.000000000 +0100