Fresh fixes for rdc from sn9, thanks !
[openwrt.git] / target / linux / rdc-2.6 / Makefile
index 323eb2c..40d6b75 100644 (file)
@@ -6,9 +6,19 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH:=i386
+BOARD:=rdc
+BOARDNAME:=RDC x86
+FEATURES:=broken squashfs jffs2
+
+define Target/Description
+        Build firmware images for RDC3211 based routers
+        (e.g. Airlink101 AR525W)
+endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))