Fresh fixes for rdc from sn9, thanks !
[openwrt.git] / target / linux / rdc-2.6 / Makefile
index 1269676..40d6b75 100644 (file)
@@ -9,23 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC x86
-FEATURES:=broken jffs2
+FEATURES:=broken squashfs jffs2
 
 define Target/Description
         Build firmware images for RDC3211 based routers
         (e.g. Airlink101 AR525W)
 endef
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
-define Profile/Ralink
-  NAME:=Ralink WiFi (default)
-  PACKAGES:=kmod-rt61
-endef
-$(eval $(call Profile,Ralink))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))