split out profile definitions from Makefiles
[openwrt.git] / target / linux / rdc-2.6 / Makefile
index f1f751e..306734b 100644 (file)
@@ -18,10 +18,7 @@ endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
-define Profile/Ralink
-  NAME:=Ralink WiFi (default)
-  PACKAGES:=kmod-rt61
-endef
-$(eval $(call Profile,Ralink))
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))