kernel: update linux 3.8 to 3.8.8
[15.05/openwrt.git] / target / linux / ramips / patches-3.8 / 0104-MIPS-ralink-add-pinmux-driver.patch
index e3bc36a..3748947 100644 (file)
@@ -17,8 +17,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  5 files changed, 85 insertions(+), 6 deletions(-)
  create mode 100644 arch/mips/ralink/pinmux.c
 
-diff --git a/arch/mips/ralink/Makefile b/arch/mips/ralink/Makefile
-index 939757f..39ef249 100644
 --- a/arch/mips/ralink/Makefile
 +++ b/arch/mips/ralink/Makefile
 @@ -6,7 +6,7 @@
@@ -30,8 +28,6 @@ index 939757f..39ef249 100644
  
  obj-$(CONFIG_SOC_RT305X) += rt305x.o
  
-diff --git a/arch/mips/ralink/common.h b/arch/mips/ralink/common.h
-index 3009903..ed99f23 100644
 --- a/arch/mips/ralink/common.h
 +++ b/arch/mips/ralink/common.h
 @@ -22,9 +22,10 @@ struct ralink_pinmux {
@@ -46,15 +42,13 @@ index 3009903..ed99f23 100644
  
  struct ralink_soc_info {
        unsigned char sys_type[RAMIPS_SYS_TYPE_LEN];
-@@ -41,4 +42,6 @@ extern void prom_soc_init(struct ralink_soc_info *soc_info);
+@@ -41,4 +42,6 @@ extern void prom_soc_init(struct ralink_
  
  __iomem void *plat_of_remap_node(const char *node);
  
 +void ralink_pinmux(void);
 +
  #endif /* _RALINK_COMMON_H__ */
-diff --git a/arch/mips/ralink/of.c b/arch/mips/ralink/of.c
-index 4165e70..ecf1482 100644
 --- a/arch/mips/ralink/of.c
 +++ b/arch/mips/ralink/of.c
 @@ -101,6 +101,8 @@ static int __init plat_of_setup(void)
@@ -66,9 +60,6 @@ index 4165e70..ecf1482 100644
        return 0;
  }
  
-diff --git a/arch/mips/ralink/pinmux.c b/arch/mips/ralink/pinmux.c
-new file mode 100644
-index 0000000..7477deb
 --- /dev/null
 +++ b/arch/mips/ralink/pinmux.c
 @@ -0,0 +1,76 @@
@@ -120,7 +111,7 @@ index 0000000..7477deb
 +              }
 +      }
 +
-+      of_property_for_each_string(np, "ralink,pinmmux", prop, pin) {
++      of_property_for_each_string(np, "ralink,pinmux", prop, pin) {
 +              int m = ralink_mux_mask(pin, rt_pinmux.mode);
 +              if (m) {
 +                      mode &= ~m;
@@ -148,8 +139,6 @@ index 0000000..7477deb
 +
 +      rt_sysc_w32(mode, SYSC_REG_GPIO_MODE);
 +}
-diff --git a/arch/mips/ralink/rt305x.c b/arch/mips/ralink/rt305x.c
-index 856ebff..d9ea53d 100644
 --- a/arch/mips/ralink/rt305x.c
 +++ b/arch/mips/ralink/rt305x.c
 @@ -97,9 +97,6 @@ struct ralink_pinmux_grp uart_mux[] = {
@@ -175,6 +164,3 @@ index 856ebff..d9ea53d 100644
        .wdt_reset = rt305x_wdt_reset,
  };
  
--- 
-1.7.10.4
-