kernel: refresh patches
[openwrt.git] / target / linux / ramips / patches-3.14 / 0048-GPIO-ralink-add-mt7621-gpio-controller.patch
index d53bbe9..25ef969 100644 (file)
@@ -12,11 +12,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  4 files changed, 187 insertions(+)
  create mode 100644 drivers/gpio/gpio-mt7621.c
 
-Index: linux-3.14.18/arch/mips/Kconfig
-===================================================================
---- linux-3.14.18.orig/arch/mips/Kconfig       2014-11-14 14:22:08.782141921 +0100
-+++ linux-3.14.18/arch/mips/Kconfig    2014-11-14 14:22:08.994149701 +0100
-@@ -437,6 +437,9 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -437,6 +437,9 @@ config RALINK
        select RESET_CONTROLLER
        select PINCTRL
        select PINCTRL_RT2880
@@ -26,11 +24,9 @@ Index: linux-3.14.18/arch/mips/Kconfig
  
  config SGI_IP22
        bool "SGI IP22 (Indy/Indigo2)"
-Index: linux-3.14.18/drivers/gpio/Kconfig
-===================================================================
---- linux-3.14.18.orig/drivers/gpio/Kconfig    2014-11-14 14:22:08.982149261 +0100
-+++ linux-3.14.18/drivers/gpio/Kconfig 2014-11-14 14:22:08.998149848 +0100
-@@ -827,6 +827,12 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -827,6 +827,12 @@ config GPIO_BCM_KONA
        help
          Turn on GPIO support for Broadcom "Kona" chips.
  
@@ -43,19 +39,15 @@ Index: linux-3.14.18/drivers/gpio/Kconfig
  comment "USB GPIO expanders:"
  
  config GPIO_VIPERBOARD
-Index: linux-3.14.18/drivers/gpio/Makefile
-===================================================================
---- linux-3.14.18.orig/drivers/gpio/Makefile   2014-11-14 14:22:08.982149261 +0100
-+++ linux-3.14.18/drivers/gpio/Makefile        2014-11-14 14:22:08.998149848 +0100
-@@ -100,3 +100,4 @@
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -100,3 +100,4 @@ obj-$(CONFIG_GPIO_WM8350)  += gpio-wm8350
  obj-$(CONFIG_GPIO_WM8994)     += gpio-wm8994.o
  obj-$(CONFIG_GPIO_XILINX)     += gpio-xilinx.o
  obj-$(CONFIG_GPIO_XTENSA)     += gpio-xtensa.o
 +obj-$(CONFIG_GPIO_MT7621)     += gpio-mt7621.o
-Index: linux-3.14.18/drivers/gpio/gpio-mt7621.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.14.18/drivers/gpio/gpio-mt7621.c   2014-11-14 14:36:19.321724539 +0100
+--- /dev/null
++++ b/drivers/gpio/gpio-mt7621.c
 @@ -0,0 +1,178 @@
 +/*
 + * This program is free software; you can redistribute it and/or modify it