ralink: add 3.18 support
[openwrt.git] / target / linux / ramips / modules.mk
index 1c84598..550a8c2 100644 (file)
@@ -5,6 +5,22 @@
 # See /LICENSE for more information.
 #
 
+OTHER_MENU:=Other modules
+define KernelPackage/sdhci-mt7620
+  SUBMENU:=Other modules
+  TITLE:=MT7620 SDCI
+  DEPENDS:=@(TARGET_ramips_mt7620||TARGET_ramips_mt7628||TARGET_ramips_mt7621) +kmod-sdhci
+  KCONFIG:= \
+       CONFIG_MTK_MMC \
+       CONFIG_MTK_AEE_KDUMP=n \
+       CONFIG_MTK_MMC_CD_POLL=n
+  FILES:= \
+       $(LINUX_DIR)/drivers/mmc/host/mtk-mmc/mtk_sd.ko
+  AUTOLOAD:=$(call AutoProbe,mtk_sd,1)
+endef
+
+$(eval $(call KernelPackage,sdhci-mt7620))
+
 I2C_RALINK_MODULES:= \
   CONFIG_I2C_RALINK:drivers/i2c/busses/i2c-ralink
 
@@ -19,3 +35,23 @@ define KernelPackage/i2c-ralink/description
 endef
 
 $(eval $(call KernelPackage,i2c-ralink))
+
+define KernelPackage/sound-mt7620
+  TITLE:=MT7620 PCM/I2S Alsa Driver
+  DEPENDS:=@TARGET_ramips_mt7620 +kmod-sound-soc-core +kmod-regmap
+  KCONFIG:= \
+       CONFIG_SND_MT7620_SOC_I2S \
+       CONFIG_SND_MT7620_SOC_WM8960
+  FILES:= \
+       $(LINUX_DIR)/sound/soc/ralink/snd-soc-mt7620-i2s.ko \
+       $(LINUX_DIR)/sound/soc/ralink/snd-soc-mt7620-wm8960.ko \
+       $(LINUX_DIR)/sound/soc/codecs/snd-soc-wm8960.ko
+  AUTOLOAD:=$(call AutoLoad,90,snd-soc-wm8960 snd-soc-mt7620-i2s snd-soc-mt7620-wm8960)
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-mt7620/description
+ Alsa modules for ralink i2s controller.
+endef
+
+$(eval $(call KernelPackage,sound-mt7620))