This patch adds a target for the IBM PowerXCell Accelerator Board.
[openwrt.git] / target / linux / pxcab / Makefile
diff --git a/target/linux/pxcab/Makefile b/target/linux/pxcab/Makefile
new file mode 100644 (file)
index 0000000..5957d65
--- /dev/null
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=pxcab
+BOARDNAME:=PowerXCell Accelerator Board
+FEATURES:=fpu ramdisk
+
+LINUX_VERSION:=2.6.30.1
+
+KERNEL_CC:=
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+       Build zImage for the IBM PowerXCell Accelerator Board
+       (aka mvXCell-8i from MatrixVision or GigaAccel 180 from Fixstars)
+endef
+
+KERNELNAME:="zImage"
+
+DEFAULT_PACKAGES += kmod-tg3
+
+$(eval $(call BuildTarget))