kernel: align the skb padding to power of two
[openwrt.git] / target / linux / ppc40x / image / Makefile
index c0ecd7f..86c238a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,12 +10,12 @@ include $(INCLUDE_DIR)/image.mk
 JFFS2_BLOCKSIZE=128k 64k
 
 define Image/Prepare
-       cp $(LINUX_DIR)/arch/powerpc/boot/uImage $(KDIR)/uImage
        $(LINUX_DIR)/scripts/dtc/dtc -O dtb -R 4 -S 0x20000 $(LINUX_DIR)/arch/powerpc/boot/dts/kilauea.dts > $(KDIR)/openwrt-kilauea.dtb
 endef
 
 define Image/BuildKernel
-       cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+       cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+       $(call Image/Build/Initramfs)
 endef
 
 define Image/Build
@@ -23,43 +23,50 @@ define Image/Build
 endef
 
 define Image/Build/ext2
-       cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-ext2.img
+       cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-ext2.img
 endef
 
 define Image/Build/jffs2-128k
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
+               dd if=$(KDIR)/uImage bs=1920k conv=sync; \
                dd if=$(KDIR)/openwrt-kilauea.dtb bs=128k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
-       ) > $(BIN_DIR)/openwrt-$(BOARD)-kilauea-jffs2.img
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-kilauea-jffs2.img
 endef
 
 define Image/Build/jffs2-64k
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1280k conv=sync; \
+               dd if=$(KDIR)/cuImage.magicbox bs=1408k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
-       ) > $(BIN_DIR)/openwrt-$(BOARD)-magicbox-jffs2.img
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-magicbox-jffs2.img
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1280k conv=sync; \
+               dd if=$(KDIR)/cuImage.openrb bs=1408k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
-       ) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-jffs2.img
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-openrb-jffs2.img
 endef
 
 define Image/Build/squashfs
        $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
+               dd if=$(KDIR)/uImage bs=1920k conv=sync; \
                dd if=$(KDIR)/openwrt-kilauea.dtb bs=128k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
-       ) > $(BIN_DIR)/openwrt-$(BOARD)-kilauea-$(1).img
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-kilauea-$(1).img
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1280k conv=sync; \
+               dd if=$(KDIR)/cuImage.magicbox bs=1408k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
-       ) > $(BIN_DIR)/openwrt-$(BOARD)-magicbox-$(1).img
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-magicbox-$(1).img
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1280k conv=sync; \
+               dd if=$(KDIR)/cuImage.openrb bs=1408k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
-       ) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-$(1).img
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-openrb-$(1).img
 endef
 
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+define Image/Build/Initramfs
+       cp $(KDIR)/cuImage.magicbox-initramfs $(BIN_DIR)/openwrt-$(BOARD)-magicbox-initramfs.bin
+       cp $(KDIR)/cuImage.openrb-initramfs $(BIN_DIR)/openwrt-$(BOARD)-openrb-initramfs.bin
+endef
+endif
+
 $(eval $(call BuildImage))