[gumstix] Add support for ubifs
[openwrt.git] / target / linux / omap35xx / gumstix / profiles / gumstix.mk
index 3cf5fab..0eae282 100644 (file)
@@ -5,20 +5,22 @@
 # See /LICENSE for more information.
 #
 
+FEATURES:=ubifs
+
 define Profile/Gumstix
   NAME:=gumstix
   PACKAGES:=-iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
                -firewall -mtd -hotplug2 -udevtrigger -dropbear \
-               ext2 usb udev kmod-bluetooth ntpclient wpa-supplicant \
+               ext4 usb udev kmod-bluetooth ntpclient wpa-supplicant \
                wireless-tools wpa-cli \
-               bluez-utils bluez-hcidump hegw usbutils python pyserial \
-               python-mini python-openssl libstdcpp \
+               bluez-utils bluez-hcidump usbutils \
                kmod-usb-serial kmod-usb-serial-cp210x kmod-usb-serial-ftdi \
                kmod-usb-serial-pl2303 kmod-usb-uhci kmod-cfg80211 \
                kmod-lib80211 kmod-libertas-sd kmod-mac80211 libnl-tiny \
-               crda iw kmod-usb-hid luci luci-app-ntpc \
-               openssh-client openssh-client-utils openssh-keygen \
-               openssh-server
+               crda iw kmod-usb-hid \
+               kmod-usb-storage kmod-usb-storage-extras \
+               kmod-fs-vfat \
+               hegw hegwtest mtd-utils
 endef
 
 define Profile/Gumstix/Description