target/linux/*/image/Makefile: use new dts path variable
[openwrt.git] / target / linux / omap / image / Makefile
index 91b9df3..ed3d90d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2012-2013 OpenWrt.org
+# Copyright (C) 2012-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,11 +11,25 @@ UBIFS_OPTS = -F -m 2048 -e 124KiB -c 4096 -U
 UBI_OPTS = -m 2048 -p 128KiB -s 512 -O 2048
 
 define Image/BuildKernel
-       cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+       $(CP) $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+       $(CP) $(KDIR)/zImage-initramfs $(BIN_DIR)/openwrt-$(BOARD)-zImage-initramfs
+ endif
+
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
+       $(INSTALL_DIR) $(TARGET_DIR)/boot
+       $(CP) $(BIN_DIR)/openwrt-$(BOARD)-zImage $(TARGET_DIR)/boot/zImage
+ endif
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
+       $(INSTALL_DIR) $(TARGET_DIR)/boot
+       $(CP) $(DTS_DIR)/am335x*.dtb $(TARGET_DIR)/boot/
+       $(CP) $(DTS_DIR)/omap3*.dtb $(TARGET_DIR)/boot/
+       $(CP) $(DTS_DIR)/omap4*.dtb $(TARGET_DIR)/boot/
+ endif
        -mkdir $(BIN_DIR)/dtbs
-       -$(CP) $(LINUX_DIR)/arch/arm/boot/dts/am335x*.dtb $(BIN_DIR)/dtbs/
-       -$(CP) $(LINUX_DIR)/arch/arm/boot/dts/omap3*.dtb $(BIN_DIR)/dtbs/
-       -$(CP) $(LINUX_DIR)/arch/arm/boot/dts/omap4*.dtb $(BIN_DIR)/dtbs/
+       -$(CP) $(DTS_DIR)/am335x*.dtb $(BIN_DIR)/dtbs/
+       -$(CP) $(DTS_DIR)/omap3*.dtb $(BIN_DIR)/dtbs/
+       -$(CP) $(DTS_DIR)/omap4*.dtb $(BIN_DIR)/dtbs/
 endef
 
 define Image/Build