upgrade 3.13 targets to 3.13.2, refresh patches
[15.05/openwrt.git] / target / linux / omap / Makefile
index 78361fc..08003d5 100644 (file)
@@ -9,16 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb targz audio display
+FEATURES:=usb usbgadget ext4 targz fpu audio display ubifs
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 
-LINUX_VERSION:=3.12
+LINUX_VERSION:=3.13.2
 
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 KERNELNAME:="zImage dtbs"
 
+include $(INCLUDE_DIR)/target.mk
+
 DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
 
 DEVICE_TYPE=developerboard
@@ -27,6 +29,4 @@ define Target/Description
        TI OMAP boards
 endef
 
-include $(INCLUDE_DIR)/target.mk
-
 $(eval $(call BuildTarget))