Merge pull request #580 from wigyori/cc-libpcap
[15.05/openwrt.git] / target / linux / octeon / Makefile
index 10849eb..e1739e7 100644 (file)
@@ -6,15 +6,15 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci usb
+FEATURES:=squashfs jffs2 ext4 initramfs pci usb
 CPU_TYPE:=octeon
-CPU_CFLAGS_octeon:=-march=octeon
+CPU_CFLAGS_octeon:=-march=octeon -mabi=64
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.10.32
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk