[target/mpc85xx]: preliminary support for Freescale MPC85xx based boards
[openwrt.git] / target / linux / mpc85xx / image / Makefile
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
new file mode 100644 (file)
index 0000000..bb99045
--- /dev/null
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+       cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
+endef
+
+define Image/BuildKernel
+       cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+endef
+
+define Image/Build/ext2
+       cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-ext2.img
+endef
+
+define Image/Build
+       $(call Image/Build/$(1),$(1))
+endef
+
+$(eval $(call BuildImage))