[lantiq] cleanup patches
[openwrt.git] / target / linux / lantiq / patches-3.3 / 0031-MIPS-lantiq-unify-xway-prom-code.patch
diff --git a/target/linux/lantiq/patches-3.3/0031-MIPS-lantiq-unify-xway-prom-code.patch b/target/linux/lantiq/patches-3.3/0031-MIPS-lantiq-unify-xway-prom-code.patch
deleted file mode 100644 (file)
index 130c694..0000000
+++ /dev/null
@@ -1,239 +0,0 @@
-From 707d76cc9dc4ddfcea280b91df83bd726407518a Mon Sep 17 00:00:00 2001
-From: John Crispin <blogic@openwrt.org>
-Date: Thu, 8 Mar 2012 11:44:55 +0100
-Subject: [PATCH 31/70] MIPS: lantiq: unify xway prom code
-
-The xway prom-ase.c and prom-xway.c files are redundant. Unify the 2 files.
-
-Signed-off-by: John Crispin <blogic@openwrt.org>
----
- arch/mips/lantiq/xway/Makefile     |    5 +--
- arch/mips/lantiq/xway/Makefile.rej |   11 -----
- arch/mips/lantiq/xway/prom-ase.c   |   48 ----------------------
- arch/mips/lantiq/xway/prom-xway.c  |   64 -----------------------------
- arch/mips/lantiq/xway/prom.c       |   79 ++++++++++++++++++++++++++++++++++++
- 5 files changed, 80 insertions(+), 127 deletions(-)
- delete mode 100644 arch/mips/lantiq/xway/Makefile.rej
- delete mode 100644 arch/mips/lantiq/xway/prom-ase.c
- delete mode 100644 arch/mips/lantiq/xway/prom-xway.c
- create mode 100644 arch/mips/lantiq/xway/prom.c
-
-Index: linux-3.3.8/arch/mips/lantiq/xway/Makefile
-===================================================================
---- linux-3.3.8.orig/arch/mips/lantiq/xway/Makefile    2012-07-31 08:34:35.000000000 +0200
-+++ linux-3.3.8/arch/mips/lantiq/xway/Makefile 2012-07-31 08:52:14.155414782 +0200
-@@ -1,7 +1,4 @@
--obj-y := sysctrl.o reset.o gpio.o gpio_stp.o gpio_ebu.o devices.o dma.o clk.o
--
--obj-$(CONFIG_SOC_XWAY) += prom-xway.o
--obj-$(CONFIG_SOC_AMAZON_SE) += prom-ase.o
-+obj-y := sysctrl.o reset.o gpio.o gpio_stp.o gpio_ebu.o devices.o dma.o clk.o prom.o
- obj-$(CONFIG_LANTIQ_MACH_EASY50712) += mach-easy50712.o
- obj-$(CONFIG_LANTIQ_MACH_EASY50601) += mach-easy50601.o
-Index: linux-3.3.8/arch/mips/lantiq/xway/prom-ase.c
-===================================================================
---- linux-3.3.8.orig/arch/mips/lantiq/xway/prom-ase.c  2012-07-31 08:34:34.000000000 +0200
-+++ /dev/null  1970-01-01 00:00:00.000000000 +0000
-@@ -1,48 +0,0 @@
--/*
-- *  This program is free software; you can redistribute it and/or modify it
-- *  under the terms of the GNU General Public License version 2 as published
-- *  by the Free Software Foundation.
-- *
-- *  Copyright (C) 2010 John Crispin <blogic@openwrt.org>
-- */
--
--#include <linux/export.h>
--#include <linux/clk.h>
--#include <asm/bootinfo.h>
--#include <asm/time.h>
--
--#include <lantiq_soc.h>
--
--#include "devices.h"
--#include "../prom.h"
--
--#define SOC_AMAZON_SE "Amazon_SE"
--
--#define PART_SHIFT    12
--#define PART_MASK     0x0FFFFFFF
--#define REV_SHIFT     28
--#define REV_MASK      0xF0000000
--
--void __init ltq_soc_detect(struct ltq_soc_info *i)
--{
--      i->partnum = (ltq_r32(LTQ_MPS_CHIPID) & PART_MASK) >> PART_SHIFT;
--      i->rev = (ltq_r32(LTQ_MPS_CHIPID) & REV_MASK) >> REV_SHIFT;
--      sprintf(i->rev_type, "1.%d", i->rev);
--      switch (i->partnum) {
--      case SOC_ID_AMAZON_SE:
--              i->name = SOC_AMAZON_SE;
--              i->type = SOC_TYPE_AMAZON_SE;
--              break;
--
--      default:
--              unreachable();
--              break;
--      }
--}
--
--void __init ltq_soc_setup(void)
--{
--      ltq_register_ase_asc();
--      ltq_register_gpio();
--      ltq_register_wdt();
--}
-Index: linux-3.3.8/arch/mips/lantiq/xway/prom-xway.c
-===================================================================
---- linux-3.3.8.orig/arch/mips/lantiq/xway/prom-xway.c 2012-07-31 08:34:34.000000000 +0200
-+++ /dev/null  1970-01-01 00:00:00.000000000 +0000
-@@ -1,64 +0,0 @@
--/*
-- *  This program is free software; you can redistribute it and/or modify it
-- *  under the terms of the GNU General Public License version 2 as published
-- *  by the Free Software Foundation.
-- *
-- *  Copyright (C) 2010 John Crispin <blogic@openwrt.org>
-- */
--
--#include <linux/export.h>
--#include <linux/clk.h>
--#include <asm/bootinfo.h>
--#include <asm/time.h>
--
--#include <lantiq_soc.h>
--
--#include "devices.h"
--#include "../prom.h"
--
--#define SOC_DANUBE    "Danube"
--#define SOC_TWINPASS  "Twinpass"
--#define SOC_AR9               "AR9"
--
--#define PART_SHIFT    12
--#define PART_MASK     0x0FFFFFFF
--#define REV_SHIFT     28
--#define REV_MASK      0xF0000000
--
--void __init ltq_soc_detect(struct ltq_soc_info *i)
--{
--      i->partnum = (ltq_r32(LTQ_MPS_CHIPID) & PART_MASK) >> PART_SHIFT;
--      i->rev = (ltq_r32(LTQ_MPS_CHIPID) & REV_MASK) >> REV_SHIFT;
--      sprintf(i->rev_type, "1.%d", i->rev);
--      switch (i->partnum) {
--      case SOC_ID_DANUBE1:
--      case SOC_ID_DANUBE2:
--              i->name = SOC_DANUBE;
--              i->type = SOC_TYPE_DANUBE;
--              break;
--
--      case SOC_ID_TWINPASS:
--              i->name = SOC_TWINPASS;
--              i->type = SOC_TYPE_DANUBE;
--              break;
--
--      case SOC_ID_ARX188:
--      case SOC_ID_ARX168:
--      case SOC_ID_ARX182:
--              i->name = SOC_AR9;
--              i->type = SOC_TYPE_AR9;
--              break;
--
--      default:
--              unreachable();
--              break;
--      }
--}
--
--void __init ltq_soc_setup(void)
--{
--      ltq_register_asc(0);
--      ltq_register_asc(1);
--      ltq_register_gpio();
--      ltq_register_wdt();
--}
-Index: linux-3.3.8/arch/mips/lantiq/xway/prom.c
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.3.8/arch/mips/lantiq/xway/prom.c   2012-07-31 08:52:14.155414782 +0200
-@@ -0,0 +1,79 @@
-+/*
-+ *  This program is free software; you can redistribute it and/or modify it
-+ *  under the terms of the GNU General Public License version 2 as published
-+ *  by the Free Software Foundation.
-+ *
-+ *  Copyright (C) 2010 John Crispin <blogic@openwrt.org>
-+ */
-+
-+#include <linux/export.h>
-+#include <linux/clk.h>
-+#include <asm/bootinfo.h>
-+#include <asm/time.h>
-+
-+#include <lantiq_soc.h>
-+
-+#include "../prom.h"
-+#include "devices.h"
-+
-+#define SOC_DANUBE    "Danube"
-+#define SOC_TWINPASS  "Twinpass"
-+#define SOC_AR9               "AR9"
-+#define SOC_VR9               "VR9"
-+
-+#define PART_SHIFT    12
-+#define PART_MASK     0x0FFFFFFF
-+#define REV_SHIFT     28
-+#define REV_MASK      0xF0000000
-+
-+#define SOC_AMAZON_SE "Amazon_SE"
-+
-+void __init ltq_soc_detect(struct ltq_soc_info *i)
-+{
-+      i->partnum = (ltq_r32(LTQ_MPS_CHIPID) & PART_MASK) >> PART_SHIFT;
-+      i->rev = (ltq_r32(LTQ_MPS_CHIPID) & REV_MASK) >> REV_SHIFT;
-+      sprintf(i->rev_type, "1.%d", i->rev);
-+      switch (i->partnum) {
-+      case SOC_ID_DANUBE1:
-+      case SOC_ID_DANUBE2:
-+              i->name = SOC_DANUBE;
-+              i->type = SOC_TYPE_DANUBE;
-+              break;
-+
-+      case SOC_ID_TWINPASS:
-+              i->name = SOC_TWINPASS;
-+              i->type = SOC_TYPE_DANUBE;
-+              break;
-+
-+      case SOC_ID_ARX188:
-+      case SOC_ID_ARX168:
-+      case SOC_ID_ARX182:
-+              i->name = SOC_AR9;
-+              i->type = SOC_TYPE_AR9;
-+              break;
-+
-+      case SOC_ID_AMAZON_SE:
-+              i->name = SOC_AMAZON_SE;
-+              i->type = SOC_TYPE_AMAZON_SE;
-+#ifdef CONFIG_PCI
-+              panic("ase is only supported for non pci kernels");
-+#endif
-+              break;
-+
-+      default:
-+              unreachable();
-+              break;
-+      }
-+}
-+
-+void __init ltq_soc_setup(void)
-+{
-+      if (ltq_is_ase()) {
-+              ltq_register_ase_asc();
-+      } else {
-+              ltq_register_asc(0);
-+              ltq_register_asc(1);
-+      }
-+      ltq_register_gpio();
-+      ltq_register_wdt();
-+}